hdu5120 Intersection(计算几何 圆)

 

                                     Intersection

            Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
                                    Total Submission(s): 4724    Accepted Submission(s): 1800


 

Problem Description

Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.

 


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.

 

 

Input

The first line contains only one integer T (T ≤ 105), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers xi, yi (0 ≤ xi, yi ≤ 20) indicating the coordinates of the center of each ring.

 

 

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.

 

 

Sample Input

 

2 2 3 0 0 0 0 2 3 0 0 5 0

 

 

Sample Output

 

Case #1: 15.707963 Case #2: 2.250778

传送门

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
double x1,ya,x2,y2;
double dis;
double s1,s2,s3;
double R,r;
double sov(double R,double r) {
    if(dis>=r+R) return 0.0;
    if(dis==0||dis<=R-r) {
        return acos(-1)*r*r;
    }
    double x=(R*R-r*r+dis*dis)/2.0/dis;
    double y=(r*r-R*R+dis*dis)/2.0/dis;
    double seta1=2*acos(x/R);
    double seta2=2*acos(y/r);
    double ans=seta1*R*R/2.0+seta2*r*r/2.0;
    double h=sqrt(R*R-x*x);
    ans-=dis*h;
    return ans;
}
int main()
{
    int t;
    int kase=0;
    scanf("%d",&t);
    while(t--) {
        scanf("%lf%lf",&r,&R);
        scanf("%lf%lf%lf%lf",&x1,&ya,&x2,&y2);
        dis=sqrt((x1-x2)*(x1-x2)+(ya-y2)*(ya-y2));
        s1=sov(R,R);
        s2=sov(R,r);
        s3=sov(r,r);
        double tot=s1-2*s2+s3;
        printf("Case #%d: ",++kase);
        printf("%.6f\n",tot);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值