Tallest Cow

题目描述

FJ's N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.
FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.
For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

 

输入

Line 1: Four space-separated integers: N, I, H and R 
Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.

 

输出

Lines 1..N: Line i contains the maximum possible height of cow i.

 

样例输入

9 3 5 5
1 3
5 3
4 3
3 7
9 8

 

样例输出

5
4
5
3
4
4
5
5
5

给出的两头牛之间可以看到,那我们让这两头牛之间所有牛--;这样,走过所以后时间为O(mn)的,所以,我们用前缀和来操作,新开数组b,第一头牛后的一头赋值为-1,第二头牛赋值为1,用c[i]的前缀和表示身高的增减,最后输出时都加h即可

#include <iostream>

#include<bits/stdc++.h>

using namespace std;

typedef long long ll;

map<pair<int,int>,bool>ese;

int c[10050],d[10050];//d数组中存影响到的段,在c数组中用前缀和更新

int main()

{

    int n,p,h,m;

    scanf("%d %d %d %d",&n,&p,&h,&m);

    for(int i=1;i<=m;i++)

    {

        int a,b;

        scanf("%d %d",&a,&b);

        if(a>b)

        {

            swap(a,b);

        }

        if(ese[make_pair(a,b)])

        {

            continue;

        }

        d[a+1]--;

        d[b]++;

        ese[make_pair(a,b)]=true;

    }

    for(int i=1;i<=n;i++)

    {

        c[i]=c[i-1]+d[i];

        printf("%d\n",h+c[i]);

    }

    return 0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值