HDU - 3336——Count the string (前缀在字符串中的出现次数)

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
Input The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
Output For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007. Sample Input
1
4
abab
Sample Output
 

6

题意:
求每一个前缀在字符中出现的次数。
前言:
这题想了两个小时半,终于自己懂得怎么做了,之前有博客过,发现有些博客代码是错的,比如aaaaa答案应该是15,而网上博客代码答案是9,更神奇的是那篇博客的代码居然过了。
思路:
用到KMP的next数组,对nextt数组的理解。发现next数组下标所指的是当前串与前缀(除本身)最大相同节点,也就是说下标next[j]所指不为0,说明之中还有与前缀相同的子串存在。
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
int t,n,ans;
int nextt[200010];
char a[200010];
void KMP()
{
    int i=0,j=-1;
    nextt[0]=-1;
    while(i<n)
    {
        if(j==-1||a[i]==a[j])
        {
            nextt[++i]=++j;
        }
        else
            j=nextt[j];
    }
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        ans=0;
        scanf("%d%s",&n,a);
        KMP();
        int j=n;
        nextt[n+1]=-1;
        for(int i=0;i<=n;i++)
        {
            if(nextt[i])
            {
                j=nextt[i];
                while(j>0)
                {
                    ans++;
                    j=nextt[j];
                }
            }
        }
        ans+=n;
        printf("%d\n",ans%10007);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值