HDU - 1075——What Are You Talking About (单词翻译)

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
Input The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
Output In this problem, you have to output the translation of the history book.
Sample Input
START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END
Sample Output
hello, i'm from mars.
i like earth!
Hint
 

Huge input, scanf is recommended.

题意:上部分是单词表,下部分是句子,翻译句子。START开始,END结束。
思路:简单字典树。网上很多代码没有判断以单词为结束的情况,虽然后台数据都以符号结束。所以不考虑也不会错。但个人感觉还是加上好,毕竟要缜密一些。
#include<algorithm>
#include<string.h>
#include<stdio.h>
char a[15],b[15],c[100000];
int tot;
int trie[1000000][26];
bool vis[1000000];
char ans[1000000][26];
void create_Trie(char *str)
{
    int root=0;
    while(*str)
    {
        int di=*str-'a';
        if(trie[root][di]==0)
        {
            trie[root][di]=++tot;
        }
        root=trie[root][di];
        str++;
    }
    vis[root]=1;
    strcpy(ans[root],a);
}
int find_Trie(char *str)
{
    int root=0;
    while(*str)
    {
        int di=*str-'a';
        if(trie[root][di]==0)
        {
            return 0;
        }
        root=trie[root][di];
        str++;
    }
    if (vis[root])return root;
    return 0;
}
int main()
{
    scanf("%s",a);
    tot=0;
    while(~scanf("%s",a),strcmp(a,"END"))
    {
        scanf("%s",b);
        create_Trie(b);
    }
    scanf("%s",a);
    getchar();
    while(gets(c),strcmp(c,"END"))
    {
        int len=strlen(c);
        int v=0;
        for(int i=0; i<=len; i++)
        {
            if(c[i]-'a'<0||c[i]-'a'>26||i==len)
            {
                a[v]='\0';
                int u=find_Trie(a);
                v=0;
                if(u)
                    printf("%s",ans[u]);
                else
                    printf("%s",a);
                if(i!=len)
                    printf("%c",c[i]);
            }
            else
                a[v++]=c[i];
        }
        printf("\n");
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值