People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:
ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.
Your mission is to count the number of ways to pay a given amount using coins of Silverland.
Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
Sample Input
2 10 30 0
Sample Output
1 4 27
题意:只有1^2,2^2,3^2——17^2,面值的硬币,求n有多少种组合方法。
思路:与HDU - 1028相同
#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
int p[20],A[1000],B[1000],n;
int main()
{
for(int i=1;i<=17;i++) p[i]=i*i;
for(int i=0;i<=300;i++) B[i]=1;
for(int i=2;i<=17;i++)
{
for(int i=0;i<=300;i++)
A[i]=B[i];
for(int k=1;p[i]*k<=300;k++)
{
for(int j=300;j>=0;j--)
{
B[p[i]*k+j]+=A[j];
}
}
}
while(~scanf("%d",&n),n)
{
printf("%d\n",B[n]);
}
}