CGL_4_A——Convex Hull(求凸包)

Convex Hull

 

Find the convex hull of a given set of points P. In other words, find the smallest convex polygon containing all the points of P. Here, in a convex polygon, all interior angles are less than or equal to 180 degrees.

Please note that you should find all the points of P on both corner and boundary of the convex polygon.

Input

n
x1 y1 
x2 y2
:
xn yn

The first integer n is the number of points in P. The coordinate of the i-th point pi is given by two integers xi and yi.

Output

In the first line, print the number of points on the corner/boundary of the convex polygon. In the following lines, print xy coordinates of the set of points. The coordinates should be given in the order of counter-clockwise visit of them starting from the point in P with the minimum y-coordinate, or the leftmost such point in case of a tie.

Constraints

  • 3 ≤ n ≤ 100000
  • -10000 ≤ xiyi ≤ 10000
  • No point in the P will occur more than once.

Sample Input 1

7
2 1
0 0
1 2
2 2
4 2
1 3
3 3

Sample Output 1

5
0 0
2 1
4 2
3 3
1 3

 

Sample Input 2

4
0 0
2 2
0 2
0 1

Sample Output 2

4
0 0
2 2
0 2
0 1

题目链接:http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=CGL_4_A

#include<bits/stdc++.h>
using namespace std;
typedef complex<double> qua;
typedef vector<qua> vec;
const double epx=1e-7;
namespace std
{
    bool operator < (const qua &a,const qua &b)
    {
        return (a.imag()==b.imag()?a.real()<b.real():a.imag()<b.imag());
    }
}
int ccw(qua a,qua b,qua c)
{
    b-=a,c-=a,a=c*conj(b);
    if(a.imag()>epx) return 1;
    if(a.imag()<-epx) return -1;
    if(a.real()<-epx) return 2;
    if(abs(b)+epx<abs(c)) return -2;
    return 0;
}
vec judge_convex(vec &v)
{
    int n=v.size(),c=0;
    vec r(n);
    for(int i=0; i<n; i++)
    {
        while(2<=c&&ccw(r[c-2],r[c-1],v[i])==-1) c--;
        r[c++] = v[i];
    }
    vec res(c);
    for(int i=0; i<c; i++) res[i]=r[i];
    return res;
}
vec calc_convex(vec &v)
{
    sort(v.begin(),v.end());
    vec u=judge_convex(v);
    reverse(v.begin(),v.end());
    vec l=judge_convex(v);
    for(int i=1; i+1<l.size(); i++) u.push_back(l[i]);
    return u;
}
int main()
{
    int n;
    double x,y;
    vec v;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%lf%lf",&x,&y);
        v.push_back(qua(x,y));
    }
    vec ans=calc_convex(v);
    printf("%d\n",ans.size());
    for(int i=0;i<ans.size();i++)
    {
        printf("%d %d\n",(int)ans[i].real(),(int)ans[i].imag());
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值