CGL_3_C——Polygon-Point Containment(点与多边形的位置关系判断)

Polygon-Point-Containment

 

For a given polygon g and target points t, print "2" if g contains t, "1" if t is on a segment of g, "0" otherwise.

g is represented by a sequence of points p1, p2,..., pn where line segments connecting pi and pi+1 (1 ≤ i≤ n−1) are sides of the polygon. The line segment connecting pn and p1 is also a side of the polygon.

Note that the polygon is not necessarily convex.

Input

The entire input looks like:

g (the sequence of the points of the polygon)
q (the number of queris = the number of target points)
1st query
2nd query
:
qth query

g is given by coordinates of the points p1,..., pn in the following format:

n
x1 y1 
x2 y2
:
xn yn

The first integer n is the number of points. The coordinate of a point pi is given by two integers xi and yi. The coordinates of points are given in the order of counter-clockwise visit of them.

Each query consists of the coordinate of a target point t. The coordinate is given by two intgers x and y.

Output

For each query, print "2", "1" or "0".

Constraints

  • 3 ≤ n ≤ 100
  • 1 ≤ q ≤ 1000
  • -10000 ≤ xiyi ≤ 10000
  • No point of the polygon will occur more than once.
  • Two sides of the polygon can intersect only at a common endpoint.

Sample Input

4
0 0
3 1
2 3
0 3
3
2 1
0 2
3 2

Sample Output

2
1
0

题目连接:http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=CGL_3_C

#include<bits/stdc++.h>
using namespace std;
typedef complex<double> qua;
vector <qua> v;
const double epx = 1e-7;
int ccw(qua a,qua b, qua c)
{
    b-=a,c-=a,a=c*conj(b);
    if(a.imag()>epx) return 1;
    if(a.imag()<-epx) return -1;
    if(a.real()<-epx) return 2;
    if(abs(b)+epx<abs(c)) return -2;
    return 0;
}
double Arg(qua a,qua b,qua c)
{
    b-=a,c-=a;
    return arg(c*conj(b));
}
int inploygon(vector<qua> &ve,qua q)
{
    int n=ve.size();
    double sum=0;
    for(int i=0;i<n;i++)
    {
        if(ccw(ve[i],ve[(i+1)%n],q)==0) return 1;
        sum+=Arg(q,ve[i],ve[(i+1)%n]);
    }
    if(abs(sum)<epx) return 0;
    else return 2;
}
int main()
{
    int n,m;
    double x,y;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%lf%lf",&x,&y);
        v.push_back(qua(x,y));
    }
    scanf("%d",&m);
    while(m--)
    {
        scanf("%lf%lf",&x,&y);
        printf("%d\n",inploygon(v,qua(x,y)));
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值