HDU6438-Buy and Resell(贪心、思维题)

题目链接

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3083    Accepted Submission(s): 1158

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:
1. spend
ai dollars to buy a Power Cube
2. resell a Power Cube and get
ai dollars if he has at least one Power Cube
3. do nothing
Obviously, Noswal can own more than one Power Cubes at the same time. After going to the
n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

 Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer
n. (1≤n≤105)
The second line has
n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all
n is no more than 5×105.

 Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input

3

4

1 2 10 9

5

9 5 9 10 5

2

2 1

Sample Output

16 4

5 2

0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16

In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5

In the third case, he will do nothing and earn nothing. profit = 0


题目大意:

有n座城市,每个城市的商品有一个固定的价格,买和卖都是这个价格。一个人从第1个城市走到第n个城市,每到一个城市可以做三件事情:买一个商品,卖一个商品(如果这个人的身上有商品),什么都不做。求这个人走遍n个城市后,收获利润的最大值。

用了贪心的思想,不过要稍微处理一下。

利润最大肯定是以最低的价格买,以最高的价格卖。利用一个最小堆将沿路的城市的价格记录,如果到达的城市的价格大于最小值,就卖。最小堆里面的数其实都是可以购买商品的价格,每到一个城市都将该城市的价格放入最小堆,这个好理解。但是可能会存在,第一个城市是1,第二个城市是2,第三个城市是3的情况,最优应该是1买3卖,获利2,交易次数2。但是实际上到达第二个城市的时候就会卖掉1。用vis数组标记该价格的商品是否卖过。如果卖过,则需要取消上次交易,因为2只是一个中间量。

价格的范围达到10^{^{9}},用普通数组会爆,用map可以解决。虽然范围很大,但是实际上最多不过城市的个数10^{^{5}},以后如果范围很大,但是实际数组用到很少的时候可以用map.

priority_queue<int,vector<int>,greater<int> > Q;铭记优先队列的写法,注意最后的> >要有空格分开。


#include <cstdio>
#include <iostream>
#include <vector>
#include <cstring>
#include <map>
#include <queue>
#define ll long long
using namespace std;

const int Max = 500010;
int a[Max];
map <int ,int>vis;//map数组可以避免过大的数据
priority_queue<int,vector<int>,greater<int> > Q;//最小堆

int main()
{
    int t,m;scanf("%d",&t);
    ll ans,time;
    while(t--)
    {
            ans = time = 0;
            vis.clear();
            scanf("%d",&m);
            for(int i=0;i<m;i++) scanf("%d",&a[i]);
            while(!Q.empty()) Q.pop();
            for(int i=0;i<m;i++){
                if(!Q.empty()&&Q.top()<a[i]){
                    int x = Q.top(); Q.pop();
                    ans += a[i] - x; time++;
                    if(vis[x]){ //卖了又买的情况
                        vis[x]--;
                        time--;
                    }
                    vis[a[i]]++;
                    Q.push(a[i]);
                }
                Q.push(a[i]);
            }
            printf("%lld %lld\n",ans,time*2);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值