A strange lift——DFS||BFS

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5 3 3 1 2 5 0

Sample Output

3

 

DFS思路

dfs遍历找到到达b楼层的最小步数。注意这里不能把vis数组单纯的当作已到达标记,如果是用BFS则可以,但是DFS不是按照步数从小到大便利的,因此dfs时,就算曾到过该点也要继续更新最小步数。

还有一点就是注意vis初始化时尽量不用0x1f这种数,用十进制数,越简单越好的那种数,否则后面if语句比较时会wa。

DFS代码

#include<bits/stdc++.h>
using namespace std;
int lift[205];
int vis[205];
int n,a,b;

void dfs(int f,int k){
//	if(k==vis[b]) return;
	if(f==b){
		vis[b]=min(k,vis[b]);
		return;
	}
	if(f+lift[f]<=n&&vis[f+lift[f]]>k+1){
		vis[f+lift[f]]=k+1;
		dfs(f+lift[f],k+1);
	}
	if(f-lift[f]>0&&vis[f-lift[f]]>k+1){
		vis[f-lift[f]]=k+1;
		dfs(f-lift[f],k+1);
	}
	return;
}

int main(){
	while(cin>>n){
		if(n==0) break;
		cin>>a>>b;
		for(int i=1;i<=n;i++){
			cin>>lift[i];
			vis[i]=250;
		}
		vis[a]=0;
		dfs(a,0);
		if(vis[b]!=250) cout << vis[b] <<endl;
		else cout << -1 <<endl;
	}
	return 0;
}

BFS思路

就常规的BFS就可以了,没啥技巧。最少步数用BFS,多少种情况用DFS。

BFS代码

#include<bits/stdc++.h>
using namespace std;
int lift[205];
int vis[205];
int n,a,b;

struct node{
	int id;
	int k;
	node(int id,int k){
		this->id=id;
		this->k=k;
	}
};

queue<node> Q;

int main(){
	while(cin>>n){
		if(n==0) break;
		while(!Q.empty()) Q.pop();
		cin>>a>>b;
		for(int i=1;i<=n;i++){
			cin>>lift[i];
			vis[i]=0;
		}
		vis[a]=1;
		Q.push(node(a,0));
		int ans=-1;
		while(!Q.empty()){
			node q=Q.front();
			Q.pop();
			if(q.id==b){
				ans=q.k;
			}
			if(q.id+lift[q.id]<=n&&!vis[q.id+lift[q.id]]){
				vis[q.id+lift[q.id]]=1;
				Q.push(node(q.id+lift[q.id],q.k+1));
			}
			if(q.id-lift[q.id]>0&&!vis[q.id-lift[q.id]]){
				vis[q.id-lift[q.id]]=1;
				Q.push(node(q.id-lift[q.id],q.k+1));
			}
		}
		cout << ans <<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值