HDOJ1548Astrangelift奇怪的电梯(BFS+队列+queue的使用方法)

                                           A strange lift

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist. 
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"? 

Input

The input consists of several test cases.,Each test case contains two lines. 
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn. 
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3

翻译版:

有一个奇怪的升降机。电梯可以随意停在每个楼层,每层楼都有一个Ki(0 <= Ki <= N)。电梯只有两个按钮:上下。当你在楼层i,如果你按下“UP”按钮,你会上升Ki楼层,即你会去i + Ki楼层,同样,如果你按下“DOWN”按钮,你会下楼Ki楼层,即您将前往i-Ki楼层。当然,升力不能高于N,并且不能低于1.例如,有5层的建筑物,k1 = 3,k2 = 3,k3 = 1,k4 = 2,k5 = 5.从1楼开始,你可以按下“UP”按钮,你就到了4楼,如果你按下“DOWN”按钮,电梯就不能做它,因为它不能下到-2楼,如你所知,-2楼不存在。问题出在这里:当你在A楼,你想要去B楼时,至少他必须按下“UP”或“DOWN”按钮多少次?输入输入由几个测试用例组成。每个测试用例包含两行。第一行包含上面描述的三个整数N,A,B(1 <= N,A,B <= 200),第二行包括N个整数k1,k2,...... kn。单个0表示输入结束。输出对于输入输出的每个情况一个整数,当你在A楼时你必须按下按钮的次数最少,而你想要去B楼。如果你不能到达B楼,则打印“-1”。

如:样品输入5 1 5 3 3 1 2 5 0

样品输出3

思路:

这一道题可以说是和我之前写的博客的那道题基本上一样,参考见:https://blog.csdn.net/rnzhiw/article/details/81414837。我觉得都是非常类似于一维的BFS迷宫,跟那一道题目可以说是基本上完全一样。

先定义一个结构体关于现在是哪一层和需要的步数的结构体,结点用node和nextnode表示。

然后输入层数和起点和终点,再输入每一层的数据,定义一个队列qu,清空队列,然后分三种情况:1.已经到达终点,2.电梯向上走,3.电梯向下走。

下面上AC代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int MAX = 11000;
struct Node//定义一个结构体关于 
{
    int to,step;
} node,nextnode;
int  v[MAX],f[MAX];//v用来标记 
int main()
{
    int cas,m,n,i;
    while(scanf("%d",&cas)&&cas)//cas表示几楼的数据 
    {
        scanf("%d%d",&m,&n);//m表示起点,n表示终点 
        memset(v,0,sizeof(v));//数组初始化 
        memset(f,0,sizeof(f));
        for(i=1; i<=cas; i++)
            scanf("%d",&f[i]);//输入每层的数据 
        queue<Node>qu;//定义队列
        while(!qu.empty())//清空队列 
        {
            qu.pop();
        }
        int  t1,t2,flag=0;
        node.step=0;//起始点的步数 
        node.to=m;
        qu.push(node);//把结点的情况输入 
        v[node.to]=1;//标记这个点已经走过了 
        while(!qu.empty())
        {
            node = qu.front();//取出首元素
            qu.pop();
            //下面是三种分类讨论:到达终点,向上走,向下走 
            if(node.to == n)//如果到达终点
            {
                printf("%d\n",node.step);
                flag=1;
                break;
            }
            t1=node.to+f[node.to];//向上走
            if(t1<=cas&&!v[t1])//条件的控制 
            {
 
                v[t1]=1;
                nextnode.to=t1;
                nextnode.step=node.step+1;
                qu.push(nextnode);
            }
            t1=node.to-f[node.to];//向下走
            if(t1>=1&&!v[t1])
            {
                v[t1]=1;
                nextnode.to=t1;
                nextnode.step=node.step+1;
                qu.push(nextnode);
            }
        }
        if(!flag)//如果走不到
            printf("-1\n");
    }
    return 0;
}

这道题也是要充分理解,理解后可以直接上类似二维的迷宫题。

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值