求最值

Description:

给定N个整数(1<=N<=100),求出这N个数中的最大值,最小值。

Input:

多组数据,第一行为一个整数N,第二行为N个不超过100的正整数,用空格隔开。

Output:

对每组数据输出一行,包含两个整数,用一个空格隔开,分别表示N个数中的最大值和最小值

Sample Input:

5
4 6 7 3 1

4
4 3 5 1

Sample Output:

7 1
5 1

 

#include <iostream>
#include <string>
#include <unordered_map>
#include <unordered_set>
#include <vector>
#include <algorithm>
#include <set>
#include <map>
#include <climits>
#include <stdio.h>
#include <iomanip>
#include <math.h>   
#include <list>
#include <stack>
#include <string.h>
using namespace std;

int main(void)
{
	int n;

	while(cin >> n)
    {
        int mymax = INT_MIN;
        int mymin = INT_MAX;
        for(;n--;)
        {
            int tmp;
            cin >> tmp;
            mymax = max(mymax, tmp);
            mymin = min(mymin, tmp);
        }
        cout << mymax << " " << mymin << endl;
    }
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值