Description:
给定N个整数(1<=N<=100),求出这N个数中的最大值,最小值。
Input:
多组数据,第一行为一个整数N,第二行为N个不超过100的正整数,用空格隔开。
Output:
对每组数据输出一行,包含两个整数,用一个空格隔开,分别表示N个数中的最大值和最小值
Sample Input:
5
4 6 7 3 1
4
4 3 5 1
Sample Output:
7 1
5 1
#include <iostream>
#include <string>
#include <unordered_map>
#include <unordered_set>
#include <vector>
#include <algorithm>
#include <set>
#include <map>
#include <climits>
#include <stdio.h>
#include <iomanip>
#include <math.h>
#include <list>
#include <stack>
#include <string.h>
using namespace std;
int main(void)
{
int n;
while(cin >> n)
{
int mymax = INT_MIN;
int mymin = INT_MAX;
for(;n--;)
{
int tmp;
cin >> tmp;
mymax = max(mymax, tmp);
mymin = min(mymin, tmp);
}
cout << mymax << " " << mymin << endl;
}
return 0;
}