requests请求出现RequestsDependencyWarning异常

对于出现该waring:

RequestsDependencyWarning: urllib3 (1.13.1) or chardet (2.3.0) doesn't match a supported version!

RequestsDependencyWarning)

解决办法:

sudo pip install --upgrade urllib3

sudo pip install --upgrade requests

根本原因是:

requests本身自带urllib3这个库的副本,在这个库的子目录下;

解决方案就是要么升级库,或者重新安装现有的版本,可以强制安装:
pip install --force-reinstall requests==xx.xx
或者升级:
pip install --upgrade requests

阅读更多
版权声明: https://blog.csdn.net/weixin_41917563/article/details/79972848
个人分类: python
相关热词: requests
上一篇ubuntu 16.04进入与退出root权限
下一篇使用Scrapy时遇到:UserWarning: You do not have a working installation of the service_identity module
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭