使用Scrapy时遇到:UserWarning: You do not have a working installation of the service_identity module

如下:

UserWarning: You do not have a working installation of the service_identity module: 'cannot import name 'opentype''.  Please install it from <https://pypi.python.org/pypi/service_identity> and make sure all of its dependencies are satisfied.  Without the service_identity module, Twisted can perform only rudimentary TLS client hostname verification.  Many valid certificate/hostname mappings may be rejected.

图:


分析问题原因:Please install it from <https://pypi.python.org/pypi/service_identity> and make sure all of its dependencies are satisfied.  

故需要在网站下载service_identity的whl组件:https://pypi.python.org/pypi/service_identity



接下来思路:

sudo pip3 install service_identity-17.0.0-py2.py3-none-any.whl(我的是安装在python3,故pip3)

又出现还未解决的一些问题:


针对这个问题,主要是一些安装包的版本不一致导致的,可直接强制更新,输入以下命令:

scrapy version(查看以下版本)

sudo pip3 install service_identity --force --upgrade

解决后,输入scrapy,如图所示:



最后,恭喜解决问题!看懂文档最重要,加油,各位码友!

阅读更多
版权声明: https://blog.csdn.net/weixin_41917563/article/details/79978819
文章标签: linux scrapy
个人分类: python scrapy linux
上一篇requests请求出现RequestsDependencyWarning异常
下一篇无题
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭