Til the Cows Come Home(最短路)

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

题意: 题意就是要问从某个点到一个固定的点的最短距离。由题可知这是一个单个源点到其他顶点的最小距离问题,由此可用Dijkstra's算法求最短路径。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <deque>
using namespace std;
	int n,t;
	int m[1001][1001];   //记录路径长度
	int dis[1001];    //到单个源点的最小距离
	bool flag[1001];   //进队标记
int main(){
	memset(m,0x3f3f3f,sizeof(m));
	memset(dis,0x3f3f3f,sizeof(dis));
	memset(flag,false,sizeof(flag));
	scanf("%d%d",&t,&n);
	dis[1]=0;
	for(int i=0;i<t;i++){
		int a,b,c;
		scanf("%d%d%d",&a,&b,&c);
		m[a][b]=m[b][a]=min(c,m[a][b]); 
	}
	deque<int>q;
	q.push_front(1);
	flag[1]=1;
        //把源点丢队列里,从源点开始遍历每个点
	while(!q.empty()){
		int k=q.front();
		flag[k]=0;
		q.pop_front();
		for(int i=1;i<=n;i++){
    //如果到当前点的距离+到下一个点的距离和小于直接到下一点距离时,则更新路径
			if(dis[k]+m[k][i]<dis[i]){     
				dis[i]=dis[k]+m[k][i];
        //这里进行SLF优化,小的放前面。如果不优化而直接让i进队也可以 
				if(!flag[i]){  
					if(!q.empty()&&dis[i]<dis[q.front()])
						q.push_front(i);
					else
						q.push_back(i);
					flag[i]=1;
				}
			}
		}	
	}
	printf("%d\n",dis[n]);
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值