HDU 1075 What Are You Talking About (stl之map映射)

What Are You Talking About
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 28482    Accepted Submission(s): 9710


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output
In this problem, you have to output the translation of the history book.

Sample Input
START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END


Sample Output
hello, i'm from mars.
i like earth!

题意:将输入字符按照输入规则翻译
分析:利用map构成映射,遇到标点或者空格时将前部分字母串翻译输出即可
 

#include<iostream>
#include<map>
#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
         string  s1,s2;
         cin>>s1;//START
         map<string,string>m;
         while(cin>>s1&&s1!="END")
                  cin>>s2,m[s2]=s1;
         cin>>s1;//START
         char s[3003];
         getchar();//去掉空行
         while(gets(s))//cin.getline(s,3003))
         {
                  if(!strcmp(s,"END"))
                           break;
                  int len=strlen(s);
                  s2="";
                  for(int i=0;i<len;i++)
                  {
                           if(s[i]>='a'&&s[i]<='z')
                                    s2+=s[i];
                           else
                           {
                                    if(m[s2]!="")//输出字符串
                                             cout<<m[s2];
                                    else
                                             cout<<s2;
                                    printf("%c",s[i]);//输出符号
                                    s2="";
                           }
                  }
                  printf("\n");
         }
         return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值