OpenJudge: Radar Installation

总时间限制: 1000ms  内存限制: 65536kB

描述

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.


Figure A Sample Input of Radar Installations

输入

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

输出

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

样例输入

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

样例输出

Case 1: 2
Case 2: 1

 分析

经典老题。

  1. 先把村庄的转化成x轴上的线段。题目变为:直线上有一组线段,要求最少的点,使得每一条线段都至少覆盖这些点中的一个。
  2. 所有线段的右端点从左到右排序,然后通过贪心的方式,挑选右端点即可。可以证明这样的点数量是最少的
    1. 最左边的点是“最左的右端点”:如果第一个点A,在“最左的右端点B”的左边,那么覆盖A的线段数量一定不超过覆盖B的线段数量,则A剩余的线段数量一定不少于B剩余的线段数量,A所需剩余点的数量一定不少于B所需剩余点的数量,故A一定不优于B;如果第一个点在“最左边的右端点”的右边,那么这个右端点对应的线段没有被覆盖到。
    2. 排除“最左边的右端点”和被覆盖的线段之后,剩余的线段同理。由归纳法可知最佳。
#include <algorithm>
#include <cmath>
#include <iostream>
#include <vector>
using namespace std;

const int N = 1005;

int handle_case(int n, int d) {
    bool is_valid = true;
    int x = 0, y = 0;
    vector<pair<double, double>> intervals;
    for (int i = 0; i < n; ++i) {
        scanf("%d%d", &x, &y);
        if (d < abs(y)) {
            is_valid = false;
        } else {
            double r = sqrt(d * d - y * y);
            intervals.push_back(make_pair(x + r, x - r));
        }
    }
    if (!is_valid) {
        return -1;
    }
    sort(intervals.begin(), intervals.end());
    int sum = 1;
    double curr = intervals[0].first;
    for (auto i = intervals.begin(); i != intervals.end(); ++i) {
        if (curr < (*i).second) {
            curr = (*i).first;
            ++sum;
        }
    }
    return sum;
}

int main() {
#ifndef ONLINE_JUDGE
    freopen("in.txt", "r", stdin);
#endif
    int n = 0, d = 0, no = 1;
    while (scanf("%d%d", &n, &d)) {
        if (n == 0 && d == 0) {
            break;
        }
        int a = handle_case(n, d);
        printf("Case %d: %d\n", no, a);
        ++no;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值