1003 Emergency (25 分)

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

题意:给出n个城市,m条道路。每个城市有一定数量的救援小组(为点权),所有边权已知,求最短路径的条数,以及最短路径最大的点权之和。

 思路:用maxw[u],表示从起点st到u的最大点权之和。num[u]表示从起点st到u的最短路径的条数,初始时只有num[s]为1,其余num[u]均为0。

#include <iostream>
#include <algorithm>
using namespace std;

const int maxn=510;
const int INF=99999999;
int G[maxn][maxn];
int weight[maxn],maxw[maxn],d[maxn],num[maxn];//点权,最大的点权之和,最短路径的距离,最短路径的条数 
bool vis[maxn];
int n,m,st,ed;

void dijkstra(int st)
{
	fill(d,d+510,INF);
	d[st]=0;
	maxw[st]=weight[st];
	num[st]=1;
	for(int i=0;i<n;i++){
		int u=-1,MIN=INF;//u使d[u]最小,MIN存放该最小的d[u] 
		for(int j=0;j<n;j++){//找未访问结点中d[]最小的 
			if(vis[j]==false&&d[j]<MIN){
				u=j;
				MIN=d[j];
			}
		}
		//找不到小于INF的d[],说明剩下的顶点和起点s不连通 
		if(u==-1){
			return ;
		}
		vis[u]=true;
		for(int v=0;v<n;v++){
			if(vis[v]==false&&G[u][v]!=INF){
				if(d[u]+G[u][v]<d[v]){
					d[v]=d[u]+G[u][v];
					maxw[v]=weight[v]+maxw[u];
					num[v]=num[u];
				}
				else if(d[u]+G[u][v]==d[v]){
					if(maxw[u]+weight[v]>maxw[v]){
						maxw[v]=maxw[u]+weight[v];
					}
					num[v]+=num[u];
				}
			}
		}
	}
}

int main()
{
	int m,st,ed;
	int u,v,l;
	scanf("%d %d %d %d",&n,&m,&st,&ed);
	for(int i=0;i<n;i++){
		scanf("%d",&weight[i]);
	}
	fill(G[0],G[0]+510*510,INF); 
	for(int i=0;i<m;i++){
		scanf("%d %d %d",&u,&v,&l);
		G[u][v]=G[v][u]=l;
	}
	dijkstra(st);
	printf("%d %d",num[ed],maxw[ed]);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值