山科java作业1-14 - 一个整数各个位上的最大数字

14 - 一个整数各个位上的最大数字

Time Limit: 1000   Memory Limit: 65535
Submit: 458  Solved: 284

Description

 

编写一个类的方法,其输入参数为一个整数,输出为该整数各个位上的最大数字。
 

Input

 

输入一个整数N

Output

 

输出该整数N各个位上的最大数字

Sample Input

 

59274

Sample Output

 

9

 

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		int n;
		Scanner scanner = new Scanner(System.in);
		n = scanner.nextInt();
		int result = getMax(n);
		System.out.println(result);

	}
	public static int getMax(int num)
	{
		int maxvalue = 0;
		while(num!= 0)
		{
			if(num%10 > maxvalue)
				maxvalue = num%10;
			num/=10;
		}
		return maxvalue;
	}

}

 

  • 0
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值