11-散列4 Hashing - Hard Version (30 分)中国大学MOOC-陈越、何钦铭-数据结构-2018秋

11-散列4 Hashing - Hard Version (30 分)

Given a hash table of size N, we can define a hash function H(x)=x%N. Suppose that the linear probing is used to solve collisions, we can easily obtain the status of the hash table with a given sequence of input numbers.

However, now you are asked to solve the reversed problem: reconstruct the input sequence from the given status of the hash table. Whenever there are multiple choices, the smallest number is always taken.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), which is the size of the hash table. The next line contains N integers, separated by a space. A negative integer represents an empty cell in the hash table. It is guaranteed that all the non-negative integers are distinct in the table.

Output Specification:

For each test case, print a line that contains the input sequence, with the numbers separated by a space. Notice that there must be no extra space at the end of each line.

Sample Input:

11
33 1 13 12 34 38 27 22 32 -1 21

Sample Output:

1 13 12 21 33 34 38 27 22 32

 

拓扑排序,最后一点一直过不了,看了别人的代码,发现自己算入度的算法有问题。。。

找最小的数时可以用优先队列,也可以暴力搜索。。。

#include<stdio.h>
#include<vector>
#define inf 99999999
using namespace std;
//int mark[1010];
int visit[1010];
int indegree[1010];
vector<int>adj[1010];//邻接表 
int main(){
	int n,i,j,count;
	scanf("%d",&n);
	count=n;
	int a[n];
	for(i=0;i<n;i++){
		scanf("%d",&a[i]);
	}
	for(i=0;i<n;i++){
		if(a[i]<0){
			indegree[i]=-1;
			count--;//除去负数后需要输出的个数 
			continue;
		}
		j=a[i]%n;
		if(j!=i){//修改了这里、、、 
			indegree[i]=(i-j+n)%n;
			int k;
			for(k=0;k<indegree[i];k++){
				adj[(j+k)%n].push_back(i);
			}
		}
//		mark[j]=1;
//		if(j!=i){
//			while(mark[j]==1){
//				adj[j].push_back(i);//
//				indegree[i]++;
//				j++;
//				j=j%n;
//			}
//			mark[j]=1;
//		} 		
	}
	int store[1010],size=0;
	for(i=0;i<count;i++){
		int min=inf,index=-1;
		for(j=0;j<n;j++){//每次找出符合要求最小的 
			if(visit[j]==0&&indegree[j]==0){
				if(a[j]<min){
					min=a[j];
					index=j;
				}				
			}
		}
		visit[index]=1;
		store[size++]=min;
		for(j=0;j<adj[index].size();j++){
			int next=adj[index][j];
			indegree[next]--;
		}
	}
	for(i=0;i<size;i++){
		printf("%d",store[i]);
		if(i<size-1){
			printf(" ");
		} 
	}
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值