用java数字三角形_[POJ1163] 动态规划入门 之 数字三角形(Java)

The Triangle

Description

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

Sample Output

30

import java.util.Scanner;

public class NumberTriangle {

//final static int MAX_NUM = 100;

static int[][] D;

static int N;

static int[][] aMaxSum;

static int MaxSum(int r, int j) {

if (r == N) {

return D[r][j];

}

if (aMaxSum[r + 1][j] == -1) {

aMaxSum[r + 1][j] = MaxSum(r + 1, j);

}

if (aMaxSum[r + 1][j + 1] == -1) {

aMaxSum[r + 1][j + 1] = MaxSum(r + 1, j + 1);

}

if(aMaxSum[r + 1][j] > aMaxSum[r + 1][j + 1]){

return aMaxSum[r + 1][j] + D[r][j];

}else{

return aMaxSum[r + 1][j + 1] + D[r][j];

}

}

public static void main(String[] args) {

Scanner in = new Scanner(System.in);

N = in.nextInt();

D = new int[N + 1][N + 1];

aMaxSum = new int[N + 1][N + 1];

for(int i = 0; i < N + 1; i++){

for(int j = 0; j < N + 1; j++){

aMaxSum[i][j] = -1;

}

}

for(int i = 1; i <= N; i++){

for(int j = 1; j <= i; j++){

D[i][j] = in.nextInt();

}

}

System.out.println(MaxSum(1,1));

}

}

这种将一个问题分解为子问题递归求解,并且将中间结果保存以避免重复计算的办法,就叫做“动态规划”。动态规划通常用来求最优解,能用动态规划解决的求最优解问题,必须满足最优解的每个局部解也都是最优的。以上题为例,最佳路径上面的每个数字到底部的那一段路径,都是从该数字出发到达底部的最佳路径。

实际上,递归的思想在编程时不一定都实现为递归函数。

动态规划一般可分为线性动规、区域动规、树形动规、背包动规四类。

线性动规:拦截导弹、合唱队形、挖地雷、建学校、剑客决斗等;

区域动规:石子合并、加分二叉树、统计单词个数、炮兵布阵等;

树形动规:贪吃的九头龙、二分查找树(BST)、聚会的欢乐、数字三角形等;

背包问题:01背包问题、完全背包问题、分组背包问题,二维背包、装箱问题、挤牛奶(同济ACM第1132题)等;

实际应用领域:最短路径问题、项目管理、网络流优化等。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值