网络流(分割点,对点有限制,一个点最多进入多少流)

这样用普通的网络流有一种情况不能加以限制(如果限制C最多进15,但这样C有可能进25),将一个点拆分成两个点和一条路就可以加以限制

这是替换之后的图像,加上了源点和汇点,这样可以通过c-C'的流量来限制进入C的流量

典型的拆点求网络流题目,因为还要输出到底哪几个相连,通过看哪两个之间流量减少了

ACM Computer Factory

As you know, all the computers used for ACM contests must be identical, so the participants compete on equal terms. That is why all these computers are historically produced at the same factory.

Every ACM computer consists of P parts. When all these parts are present, the computer is ready and can be shipped to one of the numerous ACM contests.

Computer manufacturing is fully automated by using N various machines. Each machine removes some parts from a half-finished computer and adds some new parts (removing of parts is sometimes necessary as the parts cannot be added to a computer in arbitrary order). Each machine is described by its performance (measured in computers per hour), input and output specification.

Input specification describes which parts must be present in a half-finished computer for the machine to be able to operate on it. The specification is a set of P numbers 0, 1 or 2 (one number for each part), where 0 means that corresponding part must not be present, 1 — the part is required, 2 — presence of the part doesn't matter.

Output specification describes the result of the operation, and is a set of P numbers 0 or 1, where 0 means that the part is absent, 1 — the part is present.

The machines are connected by very fast production lines so that delivery time is negligibly small compared to production time.

After many years of operation the overall performance of the ACM Computer Factory became insufficient for satisfying the growing contest needs. That is why ACM directorate decided to upgrade the factory.

As different machines were installed in different time periods, they were often not optimally connected to the existing factory machines. It was noted that the easiest way to upgrade the factory is to rearrange production lines. ACM directorate decided to entrust you with solving this problem.

Input

Input file contains integers P N, then N descriptions of the machines. The description of ith machine is represented as by 2 P + 1 integers Qi Si,1 Si,2...Si,P Di,1 Di,2...Di,P, where Qi specifies performance, Si,j — input specification for part j, Di,k — output specification for part k.

Constraints

1 ≤ P ≤ 10, 1 ≤ N ≤ 50, 1 ≤ Qi ≤ 10000

Output

Output the maximum possible overall performance, then M — number of connections that must be made, then M descriptions of the connections. Each connection between machines A and B must be described by three positive numbers A B W, where W is the number of computers delivered from A to B per hour.

If several solutions exist, output any of them.

Sample Input

Sample input 1
3 4
15  0 0 0  0 1 0
10  0 0 0  0 1 1
30  0 1 2  1 1 1
3   0 2 1  1 1 1
Sample input 2
3 5
5   0 0 0  0 1 0
100 0 1 0  1 0 1
3   0 1 0  1 1 0
1   1 0 1  1 1 0
300 1 1 2  1 1 1
Sample input 3
2 2
100  0 0  1 0
200  0 1  1 1

Sample Output

Sample output 1
25 2
1 3 15
2 3 10
Sample output 2
4 5
1 3 3
3 5 3
1 2 1
2 4 1
4 5 1
Sample output 3
0 0

Hint

Bold texts appearing in the sample sections are informative and do not form part of the actual data.

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;

//****************************************************
//最大流模板
//初始化:g[][],start,end
//******************************************************
const int MAXN=110;
const int INF=0x3fffffff;
int g[MAXN][MAXN];//存边的容量,没有边的初始化为0
int path[MAXN],flow[MAXN],start,end;
int n;//点的个数,编号0-n.n包括了源点和汇点。

queue<int>q;
int bfs()
{
    int i,t;
    while(!q.empty())q.pop();//把清空队列
    memset(path,-1,sizeof(path));//每次搜索前都把路径初始化成-1
    path[start]=0;
    flow[start]=INF;//源点可以有无穷的流流进
    q.push(start);
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        if(t==end)break;
        //枚举所有的点,如果点的编号起始点有变化可以改这里
        for(i=0;i<=n;i++)
        {
            if(i!=start&&path[i]==-1&&g[t][i])   //一定要加i!=start这个条件,因为要不然就走回路了永远走不到出口
            {
                flow[i]=flow[t]<g[t][i]?flow[t]:g[t][i];
                q.push(i);
                path[i]=t;
            }
        }
    }
    if(path[end]==-1)return -1;//即找不到汇点上去了。找不到增广路径了
    return flow[end];
}
int Edmonds_Karp()
{
    int max_flow=0;
    int step,now,pre;
    while((step=bfs())!=-1)
    {
        max_flow+=step;
        now=end;
        while(now!=start)
        {
            pre=path[now];
            g[pre][now]-=step;
            g[now][pre]+=step;
            now=pre;
        }
    }
    return max_flow;
}

int backup[MAXN][MAXN];//备份图
int in[MAXN][20];//输入信息
int Line[MAXN][4];

int main()
{
   // freopen("in.txt","r",stdin);
   // freopen("out.txt","w",stdout);
    int p;
    int N;
    while(scanf("%d%d",&p,&N)!=EOF)
    {
        memset(g,0,sizeof(g));
        for(int i=1;i<=N;i++)
        {
            for(int j=0;j<2*p+1;j++)
              scanf("%d",&in[i][j]);
        }
        for(int i=1;i<=N;i++)//拆点
        {
            g[2*i-1][2*i]=in[i][0];//自身到自身建边

        }
        n=2*N+1;
        start=0;//源点
        end=n;//汇点
        for(int i=1;i<=N;i++)
        {
            bool flag_s=true;
            bool flag_t=true;
            for(int j=0;j<p;j++)
            {
                if(in[i][j+1]==1)flag_s=false;//不能有1
                if(in[i][j+1+p]==0)flag_t=false;
            }
            if(flag_s)g[0][2*i-1]=INF;
            if(flag_t)g[2*i][n]=INF;
            for(int j=1;j<=N;j++)
               if(i!=j)
               {
                   bool flag=true;
                   for(int k=0;k<p;k++)
                     if((in[i][k+p+1]==0&&in[j][k+1]==1)||(in[i][k+p+1]==1&&in[j][k+1]==0))//注意有2的情况
                     {
                         flag=false;
                         break;
                     }
                   if(flag)g[2*i][2*j-1]=min(in[i][0],in[j][0]);
               }

        }
        memcpy(backup,g,sizeof(g));//先把图备份下来
        printf("%d ",Edmonds_Karp());
        int tol=0;
//下面是检查哪两个相连的过程
        for(int i=1;i<=N;i++)
          for(int j=1;j<=N;j++)
          {
              if(g[2*i][2*j-1]<backup[2*i][2*j-1])
              {
                  Line[tol][0]=i;
                  Line[tol][1]=j;
                  Line[tol][2]=backup[2*i][2*j-1]-g[2*i][2*j-1];
                  tol++;
              }
          }
        printf("%d\n",tol);
        for(int i=0;i<tol;i++)
        {
            printf("%d %d %d\n",Line[i][0],Line[i][1],Line[i][2]);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值