费马小定理降幂

题目

 

 

Sample Input

 

2

 

 

Sample Output

 

2

Hint

1. For N = 2, S(1) = S(2) = 1. 2. The input file consists of multiple test cases.

#include<stdio.h>
#include<string.h>
typedef long long ll;
const int mod=1e9+7;
const int maxn=1e5+5;
char str[maxn];
ll q_pow(ll a,ll b)
{
	ll ans=1;
	while(b)
	{
		if(b&1)
		{
			ans=ans*a%mod;
		}
		a=a*a%mod;
		b=b>>1;
	}
		return ans;
}
int main()
{
	while(scanf("%s",str)!=EOF)
	{
		
		ll s=0;
	    for(int i=0;i<strlen(str);i++)
		{
			s=(s*10+str[i]-'0')%(mod-1);
	    }
		ll rel;
		rel=q_pow(2,s-1);
		printf("%lld\n",rel);	
		
    }

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值