It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1 -city2 and city1 -city3 . Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2 -city3 .
Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input:
3 2 3
1 2
1 3
1 2 3
Sample Output:
1
0
0
思路
这题挺简单的哈,主要就是考对图的遍历(我这里用了DFS)。
首先,这个题的大意就是给你N个城市,M条边,然后查询K次(每次输入的编号代表该城市已被占领),然后呢,就要我们计算,如果当前查询的城市已被占领,那么还需要增加多少条路来保证剩下的城市是一个连通图。
我一开始拿到这个题目不知道该怎么做,因为对每个要查询的城市都要搜一遍,最直观的思路就是,把那个所要查询的城市抹去,并且其相关联的边也抹去,然后对剩下的城市进行搜索,看看有几个连通块,那么要增加的路就是连通块的数目-1(比如说有3个连通块,那么我最少只要修复2条路就能保证所有城市连通了)。
后来试着这么写了一下,发现极其复杂,想了一下25分的题应该不会这么难(毕竟30分的题最多也就Dijkstra+DFS),然后突然想到了搜索图时最先的操作的是判断该点是否已经被访问(vis[v]==false),那么,我只要把要查询的那个城市置为true,搜索的时候就自然而然不会搜到它了。然后问题就迎刃而解啦~
代码
#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<vector>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 1010;
vector<int> G[maxn];
bool vis[maxn] = {false};
void dfs(int u){
vis[u] = true;
for(int i=0;i<G[u].size();i++){
int v = G[u][i];
if(vis[v]==false) dfs(v);
}
}
void dfstrave(int n, int &cnt){
for(int i=1;i<=n;i++){
if(vis[i]==false){
dfs(i);
cnt++;
}
}
}
int main(){
int N, M, K;
scanf("%d%d%d", &N, &M, &K);
for(int i=0;i<M;i++){
int a, b;
scanf("%d%d", &a, &b);
G[a].push_back(b);
G[b].push_back(a);
}
for(int i=0;i<K;i++){
int tmp;
scanf("%d", &tmp);
vis[tmp] = true;//设为true,该点不再访问
int cnt = 0;
dfstrave(N, cnt);
printf("%d\n", cnt-1);
memset(vis, false, sizeof(vis));//重置vis数组,准备下一次循环
}
return 0;
}