【一只蒟蒻的刷题历程】【PAT】 A1013城市之战 (并查集)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0


题目大意:

在战争中,所有城市都必须通过高速公路连接起来,这一点至关重要。如果一个城市被敌人占领,则从该城市/往该城市的所有高速公路都将关闭。我们必须立即知道是否需要维修其他高速公路以保持其余城市的连通性。在标记了所有剩余高速公路的城市地图上,您应该告诉我们需要快速修复的高速公路数量。

例如,如果我们有3个城市和2条连接城市1-城市2和城市1-城市3的高速公路。然后如果城市1被敌人占领,我们必须修好1条高速公路,即高速公路城市2-城市3。

输入规格:

每个输入文件包含一个测试用例。每种情况都从包含3个数字N(<1000),M和K的行开始,分别是城市总数,剩余高速公路数量和要检查的城市数量。然后是M条线,每条线用2个整数描述一条高速公路,这是该高速公路连接的城市的数量。城市从1到N编号。最后一行包含K号,代表我们关注的城市。

输出规格:

对于K个城市中的每个城市,如果一条城市丢失,则需要对一条高速公路上的高速公路数量进行修补。

样本输入:

3 2 3
1 2
1 3
1 2 3

样本输出:

1个
0
0


思路:

并查集,然后判断去除某个点后这个图被分成几个连通块(集合),最少需要的边是连通块数减1;;

坑点一(最后一个测试点):题目没说最多几条边,一开始看错了,以为也是1000,没想到居然没说,后来开了很大才过了,虽然我没用vector,还是推荐包装一下pair,因为不知道到底要多少边。。。。

坑点二(最后一个测试点):还有用cin和cout有一次侥幸过了(就是上面刚改完pair的大小时过了,376ms),多交几次就过不了运行超时,很迷。。。所以要用scanf和printf(164ms),快了好多。。。

代码:

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <queue>
#include <set>
#include <map>
using namespace std;
int n,m,k;
int a,b;
int father[1100];
pair<int,int> g[1100000];
 /*存边 (巨坑无比,开了1100第五个测试点一直没过,不断加大)
   推荐用个vector包装一下  */
int find(int x)  //找根
{
	return x==father[x]?x:father[x]=find(father[x]);
	/*父亲结点是自己,代表是祖先,否则找父亲的祖先,以此往上,
	找的过程中顺便压缩一下路径*/
}

void init()
{
	for(int i=1;i<1100;i++) //初始化,每个人都是自己的祖先
	  father[i] = i;
}

void Union(int a,int b) //合并
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb)
	  father[fa] = fb;
}

int build(int x)
{
	init();
	for(int i=0;i<m;i++)
	if(g[i].first!=x && g[i].second!=x) //不出现这个点,才合并
	 Union(g[i].first , g[i].second);
	 
	int sum=0; //计数,不计被删去的这个点,所以i!=x
	for(int i=1;i<=n;i++)
	  if(father[i]==i && i!=x) sum++;
	return sum-1;  //最少的边为连通块数(集合数)-1
}

int main() 
{
   cin>>n>>m>>k;
   for(int i=0;i<m;i++)
   {
   	  scanf("%d%d",&a,&b);
   	  g[i] = {a,b};  //存边
   }
   
   int x;
   for(int i=0;i<k;i++)
   {
   	  scanf("%d",&x);
   	  printf("%d\n",build(x));
   }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值