PAT甲级刷题记录——1092 To Buy or Not to Buy (20分)

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.
在这里插入图片描述
Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

思路

这题很简单哈,题目大意就是让你计算店家给出的珠子能否满足Eva同学的需求,如果满足,输出Yes,并输出她额外需要购买的珠子数(其实就是两个字符串长度的差值),如果不满足,输出No,并计算差了几个珠子(比如题目中的2和3,第3个是Eva想要的,而第2个差了1个红色和1个黑色,因此输出2)。

我的做法就是建立两个char到int的map,然后把店家和Eva的两个字符串都映射起来(颜色->珠子数),然后再遍历Eva的串,每找到一个对应的颜色,就在Eva的map里和店家的map里比较这个颜色,如果Eva需要的珠子数大于店家给出的珠子数,那么说明这种方案是不行的,于是先把flag置为false,然后再在cnt中累加上需求和给出的珠子数相差的数量。

这里呢需要再用一个map来判断是否已经访问过当前颜色,否则就会重复访问导致cnt累加出错。比如,图1里第3行的红色珠子是要计算的,如果不记录已经访问当前颜色的话,就会出现碰到前一个红珠子,累加一次1,碰到后一个红珠子,又累加一次1,最后输出3(实际上应该输出2)。

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<map>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
map<char, int> m1;
map<char, int> m2;
map<char, bool> vis;
int main()
{
    string ShopOwner, Eva;
    cin>>ShopOwner>>Eva;
    for(int i=0;i<ShopOwner.length();i++){
        m1[ShopOwner[i]]++;
    }
    for(int i=0;i<Eva.length();i++){
        m2[Eva[i]]++;
    }
    bool flag = true;
    int cnt = 0;
    for(int i=0;i<Eva.length();i++){
        if(m2[Eva[i]]>m1[Eva[i]]&&vis[Eva[i]]==false){
            flag = false;
            vis[Eva[i]] = true;//为了防止重复计算缺少的那个珠子
            cnt += m2[Eva[i]]-m1[Eva[i]];
        }
    }
    if(flag==true) cout<<"Yes "<<ShopOwner.length()-Eva.length();
    else cout<<"No "<<cnt;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值