PAT甲级刷题记录——1144 The Missing Number (20分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​ ). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

思路

这题很简单哈,但是我却卡了一会时间(原因是在于输入数据的时候动态更新最大值最小值,然后在[最小值,最大值]这个区间范围内寻找尚未出现过的最小正整数,结果一直只有头和尾两个测试点过了……后来干脆删了从1遍历到INF就AC啦~应该是什么地方写错了叭hhh)。

这里我直接用了map来建立int对bool的映射(用bool数组最后一个测试点会段错误,所以我就换回map了~),凡是读入一个正数,就把它置true(因为我们要寻找的是列表中尚未给出的最小正整数,因此,可以认为负数是无效数据,干脆跳过就好了)。最后,遍历所有正数(从1到INF,这里INF我只取了123123123,没有取到int型的最大值,事实证明没有测试点是故意取int最大值的),如果找到某个正数在map中为false,那么直接输出并且break掉即可~

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<map>
#include<string.h>
#include<iostream>
using namespace std;
const int INF = 123123123;
map<int, bool> m;
int main()
{
    int N;
    scanf("%d", &N);
    for(int i=0;i<N;i++){
        int tmp;
        scanf("%d", &tmp);
        if(tmp>0){
            m[tmp] = true;
        }
    }
    for(int i=1;i<=INF;i++){
        if(m[i]==false){
            printf("%d", i);
            break;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值