「1144」The Missing Number

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer . Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

Ω

给出一个整数序列,输出序列中不存在的最小正整数。

注意到 最大也才 ,因此答案一定在 中。我们开一个 大小(最后一个索引是 )的bool数组,并初始化索引指针为1。每次读入一个数,如果是一个 的【正】整数,那么将其索引的bool值置true,同时往后移动(也可能不移动)索引指针到第一个值为false的索引。最后直接输出索引指针。


🐎

#include <iostream>
#include <vector>

using namespace std;

int main()
{
    int n, k, ans = 1;
    scanf("%d", &n);
    vector<bool> pos(1e5 + 2, false);
    for (int i = 0; i < n; ++i)
    {
        scanf("%d", &k);
        if (k <= 1e5 && k > 0) pos[k] = true;
        while (pos[ans]) ++ans;
    }
    printf("%d", ans);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值