PAT Advanced 1001 A+B Format

1001 A+B Format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

解题思路

计算 A+B的问题,但是要注意输出的格式,每三个数字就输出一个, 还要注意测试点 4> 出现计算sum 为0的时候避免 输出为空的情况

解题代码

#include <cstdio>
int a, b, sum, len, c[100];
bool flag;
int main(){
    scanf("%d %d", &a, &b);
    sum = a + b;
    if (sum < 0) sum = -sum, flag = true;
    if (sum == 0) c[len++] = 0;
    while(sum > 0){
        c[len ++] = sum % 10;
        sum /= 10;
    }
    if (flag) printf("-");
    for (int i = len - 1; i >= 0; i--){
        printf("%d", c[i]);
        if (i > 0 && i % 3 == 0) printf(",");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值