PAT Advanced 1086 Tree Traversals Again

1086 Tree Traversals Again

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

img
Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop 

Sample Output:

3 4 2 6 5 1

解题思路

通过stack模拟, push表示二叉树的前序值,pop表示二叉树的中序的值。 完成输入后则得到中序和前序遍历结果。通过中序和前序构建二叉树(建立的过程类似于1020)之后,后序遍历输出即可。

解题代码

#include <iostream>
#include <stack>
#include <cstdio>
using namespace std;
int n, lenp, leni, cnt, pre[30], in[30];
string op;
stack<int> st;
struct node{
    int data;
    node* lchild;
    node* rchild;
};
void post(node* root){
    if (root == NULL) return;
    post(root->lchild);
    post(root->rchild);
    printf("%d", root->data);
    cnt ++;
    if (cnt < n) printf(" ");
}
node* create(int preL, int preR, int iL, int iR){
    if (preL > preR) return NULL;
    node* root = new node;
    root->data = pre[preL];
    int k;
    for (k = iL ; k < iR; k++)
        if (in[k] == pre[preL]) break;
    int numberL = k - iL;
    root->lchild = create(preL + 1, preL + numberL, iL, k - 1);
    root->rchild = create(preL + numberL + 1, preR, k + 1, iR);
    return root;
}
int main(){
    scanf("%d", &n);
    for (int i = 0; i < 2 * n; i++){
        cin >> op;
        if (op == "Push"){
            int t;
            scanf("%d",&t);
            pre[lenp++] = t;
            st.push(t);
        } else{
            in[leni++] = st.top();
            st.pop();
        }
    }
    node* root = create(0, n - 1, 0, n - 1);
    post(root);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值