【简单搜索】Catch That Cow

Catch That Cow

问题描述

Farmer John has been informed of the location of a fugitive cow and
wants to catch her immediately. He starts at a point N (0 ≤ N ≤
100,000) on a number line and the cow is at a point K (0 ≤ K ≤
100,000) on the same number line. Farmer John has two modes of
transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long
does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John
to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move
along the following path: 5-10-9-18-17, which takes 4 minutes.

代码样例

//C-catch that cow
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
#define MAXN 100000
using namespace std;
int jhon, cow;
int vist[MAXN];
struct node{
	int postition, step; 
};
int to(int postition, int index){
	if(index==0){
		return postition+1;
	}else if(index==1){
		return postition-1;
	}else if(index==2){
		return 2*postition;
	}
}
int check(node N){
	if(N.postition<0||N.postition>MAXN||vist[N.postition]==1){
		return 1;
	}
	return 0;
}
int bfs(){
	node present, next;
	queue<node> Q;
	present.postition=jhon;
	present.step=0;
	vist[present.postition]=1;;
	Q.push(present);
	while(!Q.empty()){
		present=Q.front();
		Q.pop();
		if(present.postition==cow){
			return present.step;
		}
		for(int i=0; i<3; i++){
			next=present;
			next.postition=to(next.postition, i);
			if(check(next)){
				continue;
			}
			vist[next.postition]=1;
			next.step++;
			Q.push(next);
		}
	}
	return 0;
}
int main(void){
	scanf("%d %d", &jhon, &cow);
	memset(vist, 0, sizeof(vist));
	int ans;
	ans=bfs();
	printf("%d\n", ans);
	return 0;
}

这也是一个简单的bfs问题。
这题简单的多。

  • 1605集训计划第三天任务
  • 提前完成
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值