Root of AVL Tree

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N () which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

#include<stdio.h>
#include<stdlib.h>

typedef struct AVLNode *AVLTree;
struct AVLNode{
	int Data;
	AVLTree left;
	AVLTree right;
	int h;
};

AVLTree BuiltTree(int V);
AVLTree SingleLeftRotation(AVLTree A);
AVLTree SingleRightRotation(AVLTree A);
AVLTree DoubleLeftRightRotation(AVLTree A);
AVLTree DoubleRightLeftRotation(AVLTree A);
AVLTree Insert(AVLTree T,int X);
int Max(int a,int b);
int Geth(AVLTree T);

int main()
{
	int N,i,V;
	AVLTree T;
	
	scanf("%d",&N);
	scanf("%d",&V);
	T=BuiltTree(V);
	for(i=1;i<N;i++)
	{
		scanf("%d",&V);
		T=Insert(T,V);
	}
	printf("%d\n",T->Data);
	return 0;
}

int Max(int a,int b)
{
	return a>b?a:b;
}

int Geth(AVLTree T)
{
	if(T)
		return T->h;
	else
		return 0;
}

AVLTree BuiltTree(int V)
{
	AVLTree T=(AVLTree)malloc(sizeof(struct AVLNode));
	T->Data =V;
	T->left=NULL;
	T->right=NULL;
	T->h=1;
	return T;
}

AVLTree SingleLeftRotation(AVLTree A)
{
	AVLTree B=A->left;
	A->left=B->right;
	B->right=A;
	A->h=Max(Geth(A->left),Geth(A->right))+1;
	B->h=Max(Geth(B->left),A->h)+1;
	return B;
}

AVLTree SingleRightRotation(AVLTree A)
{
	AVLTree B=A->right;
	A->right=B->left;
	B->left=A;
	A->h=Max(Geth(A->left),Geth(A->right))+1;
	B->h=Max(Geth(B->right),A->h)+1;
	return B;
}

AVLTree DoubleLeftRightRotation(AVLTree A)
{
	A->left=SingleRightRotation(A->left);
	return SingleLeftRotation(A);
}

AVLTree DoubleRightLeftRotation(AVLTree A)
{
	A->right=SingleLeftRotation(A->right);
	return SingleRightRotation(A);
}

AVLTree Insert(AVLTree T,int X)
{
	 if(!T)
	 {
	 	T=BuiltTree(X);
	 }
	 else if(X<T->Data)
	 {
	 	T->left=Insert(T->left,X);
	 	if(Geth(T->left)-Geth(T->right)==2)
	 		if(X<T->left->Data)
	 			T=SingleLeftRotation(T);
	 		else
	 			T=DoubleLeftRightRotation(T);
	 }
	 else if(X>T->Data)
	 {
	 	T->right=Insert(T->right,X);
	 	if(Geth(T->left)-Geth(T->right)==-2)
	 		if(X>T->right->Data)
	 			T=SingleRightRotation(T);
	 		else
	 			T=DoubleRightLeftRotation(T);
	 }
	 T->h=Max(Geth(T->left),Geth(T->right))+1;
	 return T;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值