pat 甲级 图 A1142 Maximal Clique (25分)团

1142 Maximal Clique (25分)

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

参考柳神: https://blog.csdn.net/liuchuo/article/details/79618797

#include<iostream>
#include<vector>
using namespace std;
int main(){
	int nv,ne,m,k,e[220][220],a,b;
	cin>>nv>>ne;
	for(int i=0;i<ne;i++){
		scanf("%d %d",&a,&b);
		e[a][b]=e[b][a]=1;
	}
	cin>>m;
	for(int i=0;i<m;i++){
		scanf("%d",&k);
		vector<int> v(k);
		int hash[220]={0},isClique=1,isMax=1;
		for(int j=0;j<k;j++){
			scanf("%d",&v[j]);
			hash[v[j]]=1;
		}
		for(int j=0;j<k;j++){
            if(isClique==0) break;
			for(int l=j+1;l<k;l++){
				if(e[v[j]][v[l]]==0){
					printf("Not a Clique\n");
					isClique=0;
					break;
				}
			}
		}
		if(isClique==0) continue;
		for(int j=1;j<=nv;j++){
			if(hash[j]==0){//选取不是所给查询集合中的点j
				for(int l=0;l<k;l++){
					if(e[v[l]][j]==0) break;
					if(l==k-1) isMax=0;//存在点j可以和所给查询集合中的所有点相连
				}
			}
			if(isMax==0){
				printf("Not Maximal\n");
				break;
			}
		}
		if(isMax==1) printf("Yes\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值