PAT 1107 Social Clusters

12 篇文章 0 订阅
10 篇文章 0 订阅

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

上次考PAT就吃了不会找并查集每个分组中心点的亏,这次正好弥补,看了网上大佬们的算法得到的结果,如下:

#include <iostream>
#include <map>
#include <vector>
#include <algorithm>
using namespace std;
bool cmp(int x,int y){
    return x>y;
}
int find(int i,int* array){
    while (i!=array[i]){
        i=array[i];
    }
    return i;
}
void setUnion(int i,int j,int* array,int *isRoot){
    int find_i=find(i,array);
    int find_j=find(j,array);
    array[find_i]=find_j;
    if(find_i!=find_j) {
        isRoot[find_j] = isRoot[find_j] + isRoot[find_i];
        isRoot[find_i] = 0;
    }
}
int main() {
    int N;
    cin>>N;
    int array[N+1];
    int isRoot[N+1];//定义每个分组的根节点,如果为0不是根节点,如果不为0代表根节点,值为此分组元素数
    for (int i = 0; i <=N ; ++i) {
        isRoot[i]=1;
        array[i]=i;
    }
    map<int,int> map1;
    for (int i = 1; i <= N; ++i) {
        int num;
        scanf("%d:",&num);
        for (int j = 0; j < num; ++j) {
            int val;
            scanf("%d",&val);
            if(map1[val]==0){
                map1[val]=i;
            } else{
                setUnion(map1[val],i,array,isRoot);
            }
        }
    }
    sort(isRoot+1,isRoot+N+1,cmp);
    int count=0;
    for (int i = 1; i <N+1 ; ++i) {
        if (isRoot[i]!=0){
            count++;
        }
    }
    cout<<count<<endl;
    if(count==0){
        return 0;
    }
    cout<<isRoot[1];
    for (int i = 2; i <= count; ++i) {
       cout<<" "<<isRoot[i];
    }
    return 0;
}

并查集版本较为复杂,还是深度优先搜索好用。。。

#include <iostream>
#include<vector>
#include<map>
#include<cstring>
#include<algorithm>
using namespace std;
map<int,vector<int>> graph;
bool visited[1005];
int cnt;
void dfs(int x){
    visited[x]=true;
    cnt++;
    for(int a:graph[x]){
        if(!visited[a]){
            dfs(a);
        }
    }
}
bool cmp(int a,int b){
    return a>b;
}
int main()
{
    int N;
    cin>>N;
    map<int,int> map1;
    for(int i=0;i<N;i++){
        int K;
        scanf("%d:",&K);
        for(int j=0;j<K;j++){
            int val;
            cin>>val;
            if(map1[val]==0){
                map1[val]=i+1;
            }else{
                graph[map1[val]].push_back(i+1);
                graph[i+1].push_back(map1[val]);
            }
        }
    }
    memset(visited,false,sizeof(graph));
    vector<int> res;
    for(int i=1;i<=N;i++){
        cnt=0;
        if(!visited[i]){
            dfs(i);
            res.push_back(cnt);
        }
    }
    cout<<res.size()<<endl;
    sort(res.begin(),res.end(),cmp);
    cout<<res[0];
    for(int i=1;i<res.size();i++){
        cout<<" "<<res[i];
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值