PAT 1107 Social Clusters(30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

思路:并查集,如果两个人具有相同的爱好则是同一个集合。

程序:

#include <cstdio>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
using namespace std;
int father[1001];
void init()
{
  for(int i = 0; i < 1001; i++)
  {
    father[i] = i;
  }
}
int findRoot(int x)
{
  while(father[x] != x)
  {
    x = father[x];
  }
  return x;
}
void Union(int a, int b)
{
  int x = findRoot(a);
  int y = findRoot(b);
  if(x < y)
    father[y] = x;
  else
    father[x] = y;
}
int main()
{
  int n;
  scanf("%d",&n);
  init();
  vector<vector<int> > v(n+1);
  for(int i = 1; i <= n; i++)
  {
    int k;
    scanf("%d:",&k);
    for(int j = 0; j < k; j++)
    {
      int tmp;
      scanf("%d",&tmp);
      v[i].push_back(tmp);
    }
  }
  for(int i = 1; i <= n; i++)
  {
    for(int j = i + 1; j <= n; j++)
    {
      bool flag = false;
      for(int k = 0; k < v[i].size(); k++)
      {
        for(int t = 0; t < v[j].size(); t++)
        {
          if(v[i][k] == v[j][t])
          {
            Union(i,j);
            flag = true;
            break;
          }
        }
        if(flag)
          break;
      }
    }
  }
  map<int,int> mymap;
  for(int i = 1; i <= n; i++)
  {
    int fa = findRoot(i);
    mymap[fa]++;
  }
  map<int,int>::iterator it = mymap.begin();
  vector<int> vv;
  for(; it != mymap.end(); it++)
  {
    vv.push_back(it->second);
  }
  sort(vv.begin(),vv.end());
  printf("%d\n",vv.size());
  for(int i = vv.size() - 1; i >= 0; i--)
  {
    printf("%d",vv[i]);
    if(i > 0)
      printf(" ");
  }
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值