PAT甲级1011 World Cup Betting (20分)|C++实现

一、题目描述

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:
W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

​​Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

二、解题思路

20分题,不是很难。题目大意就是给你三场比赛的下注数据,让你找出可能获得的最大利润,以及每场比赛数字(赔率?)最大的结果。要找出三个数字中的最大值,可以直接用一行代码max(max(w, t), l)来求出(头文件必须包含algorithm)。之后将每场比赛的最大值累乘起来。我这里用vector<char>来存放每场比赛数字最大的结果,即W, T, L。最后遍历这个vector进行输出,再打印出来(sum*0.65-1)*2即可。(注:这里笔者当时用的是变量名是sum,sum表示累乘结果)

三、AC代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
int main()
{
    double sum=1.0, w, t, l, tmp;
    vector<char> ans;
    for(int i=0; i<3; i++)
    {
        scanf("%lf%lf%lf", &w, &t, &l);
        tmp = max(max(w, t), l);
        sum *= tmp;
        if(tmp == w)	ans.push_back('W');
        else if(tmp == t)	ans.push_back('T');
        else	ans.push_back('L');
    }
    for(int i=0; i<ans.size(); i++)
        printf("%c ", ans[i]);
    printf("%.2f", (sum*0.65-1)*2);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值