1023 Have Fun with Numbers (20 分)

1023 Have Fun with Numbers (20 分)

题意

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

答案

几个注意的tip

  • 结构里面的初始化,只能在c++里面用。如果用c编译器,无法通过。
  • 对于一个超过long long int 的整数,运算,一般的操作是: 字符串读入 >> 转化为int类型数组,当然,从低位开始 >>开始运算,过10进1
  • 本题题解的特点还在于其高度结构化,做起来很舒服。
#include<cstdio>
#include<string.h>
#include<stdio.h>
struct bign {
	int d[21];
	int len;
	bign () {
		memset(d,0,sizeof(d));
		len = 0;
	}
};

bign change (char str[]) {
	bign a;
	a.len = strlen(str);
	for(int i = 0; i < a.len; i ++) {
		a.d[i] = str[a.len - 1 - i] - '0';
	}
	
	return a;
}

bign multi(bign a, int n) {
	bign c;
	int carry = 0;
	for(int i = 0; i < a.len; i ++) {
		int temp = a.d[i] * 2 + carry;
		c.d[c.len ++] = temp % 10;
		carry = temp / 10;
	}
	
	while(carry > 0) {
		c.d[c.len ++] = carry % 10;
		carry /= 10;
	} 
	
	return c;
} 
bool Judge (bign a, bign b) {
	if(b.len > a.len) return false;
	int count[10] = {0};
	for(int i = 0; i < a.len; i ++) {
		count[a.d[i]] ++;
		count[b.d[i]] --;
	}
	
	for(int i = 0; i < 10; i ++) {
		if(count[i] != 0) {
			return false;
		}
	}
	return true;
}

void print(bign a) {
	for(int i = a.len - 1; i >= 0; i --) {
		printf("%d",a.d[i]);
	}
}
int main()
{
	char str[21];
	//gets(str);
    scanf("%s",str);
	bign a = change(str);
	bign mul = multi(a,2);
	if(Judge(a,mul) == true) printf("Yes\n");
	else printf("No\n");
	print(mul);
	return 0;
}

题目链接

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 回答1: “fun with even subarrays” 的意思是“玩转偶数子数组”,其中“偶数子数组”指的是数组中元素个数为偶数的子数组。这个话题可能涉及到数组的遍历、子数组的生成、偶数个元素的判断等等。具体的实现方法和应用场景需要根据具体情况来确定。 ### 回答2: "fun with even subarrays" 可以理解为与偶数子数组有趣的互动。 一个子数组是指原数组中连续的一部元素组成的数组,而偶数子数组则是指子数组中包含偶数个元素的子数组。 与偶数子数组的互动可以通过以下方式实现: 1. 统计偶数子数组的个数:遍历原数组,判断每个子数组的长度是否为偶数,并计数出现的次数。可以使用一个计数器来记录偶数子数组的出现次数。 2. 打印偶数子数组:遍历原数组,并使用嵌套循环来找到所有的偶数子数组。对于每个子数组,判断其长度是否为偶数,如果是则打印该子数组。这样可以将所有的偶数子数组输出到控制台或其他地方,以供查看和析。 3. 操作偶数子数组:根据偶数子数组的位置和元素,可以进行各种操作。例如,可以对偶数子数组中的元素进行排序、求和、求平均值等计算,也可以将偶数子数组的元素进行修改、替换等操作。这样可以深入了解和探索偶数子数组的特性和性质。 4. 寻找特定结构的偶数子数组:可以在原数组中寻找特定结构的偶数子数组,例如找到长度为4的偶数子数组,或者找到和为特定值的偶数子数组等。这样可以在偶数子数组中发现规律和模式,并进行进一步的研究和析。 总之,“fun with even subarrays”是一种有趣的互动方式,可以通过统计、打印、操作和寻找特定结构的偶数子数组来深入理解和探索原数组中偶数子数组的性质和特点。 ### 回答3: 趣味性是人们在日常生活中追求的一种心理满足。而对于连续子数组这样的概念,我们可以通过一些有趣的方法进行探索。 首先,我们可以通过游戏的方式来增加连续子数组的趣味性。比如,可以设计一个游戏规则,要求玩家在一个给定的数组中找到所有的偶数子数组。玩家需要快速地遍历数组,并标记出所有满足条件的子数组。这样一来,寻找偶数子数组就变成了一个有趣的挑战,增加了游戏的趣味性。 此外,我们还可以通过一些算法和技巧来解决连续子数组的问题,从而使之更加富有趣味性。比如,可以使用动态规划算法来求解最长的连续偶数子数组,或者设计一种巧妙的数据结构来快速找到所有的偶数子数组。这样一来,我们不仅可以提升连续子数组问题的解决效率,还可以增加问题本身的趣味性。 最后,我们还可以将连续子数组的概念与其他有趣的问题进行结合,从而创造出更多有趣的问题。比如,我们可以设计一个题目,要求在一个数组中找到和最大的偶数子数组;或者设计一个游戏,要求玩家通过调整数组中的数字,使得所有的子数组都是偶数。这样一来,连续子数组的概念就与其他问题产生了有趣的结合,使得问题解决过程更加有趣。 总之,通过游戏化、算法优化以及与其他问题的结合,我们可以使连续子数组问题更加有趣。无论是解决问题的过程,还是问题本身的设计,都可以通过一些巧妙的思路来提升趣味性。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值