Have Fun with Numbers

Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

题目解析

输入一串数字,最多20个,判断这串数字乘以2后得到的另一串数字的位数是否与原先相同,且是否是由原先数字组成的。数字相比,多一个不行,少一个不行。相同yes,不同no
例:原本921,三位。变化后,1842。位数不同,且数字不是由原来的数字变换位置组成的。

数字过大,用数组,单个单个数字解决更为妥当。
第一遍提交出错了,由于没考虑位数不同后的输出,要把多出的那位也输出出来,直接有针对的解决,看第一位数的2倍,除以10后是不是0。
是0说明位数没有增加,正常输出。
不是0,则说明位数增加,把这个数先输出,在输出变化后的数组。

public class Program
{
    public static void Main()
    {
        string line;
        while ((line = System.Console.ReadLine()) != null)
        {
            bool flag = true;
            int[] a = new int[line.Length];
            int[] test = new int[10]{0,0,0,0,0,0,0,0,0,0};
            //两个数组一个存储输入数字串
            //第二个是容量为9 ,分别代表0-9数字出现的次数,出现某数,test[某数]++
            for (int i = 0; i < line.Length; i++)
            {
                a[i] = int.Parse(line.Substring(i, 1));
                test[a[i]]++;//对应数字增加
            }
            //判断位数是否相同,位数增加改变test数组
            int num = a[0] * 2 / 10;
            if (num != 0)
            {
                test[num]--;
            }
            //数组变化,得到新数组
            int t = 0,te=0;
            for (int i = a.Length - 1; i >= 0; i--)
            {
                te = t;
                a[i] *= 2;
                t = a[i] / 10;
                a[i] = a[i] % 10 + te;
                test[a[i]]--;//对应数字减少
            }
            //遍历test,看数字有没有多的,
            for (int i = 0; i < test.Length; i++)
            {
                if (test[i] != 0)
                {
                    flag = false;
                    break;
                }
            }
            if (flag)
            {
                System.Console.WriteLine("Yes");
            }
            else
                System.Console.WriteLine("No");
            //输出,先看位数加没加
            if (num != 0)
            {
                System.Console.Write(num); ;
            }
            for (int i = 0; i < a.Length; i++)
            {
                System.Console.Write(a[i]);
            }
        }
        System.Console.ReadKey();
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值