1025 PAT Ranking (25分)

该博客介绍了一项任务,即合并多个编程能力测试(PAT)的排名列表,并生成最终的排名。输入包含各个测试地点的排名信息,输出要求按照最终排名、注册号和本地排名排序。博主分享了思路,强调了相同分数时按编号排序以及处理大数据量时算法效率的重要性,并给出了代码实现。
摘要由CSDN通过智能技术生成

题目

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N ( ≤ 100 ) N (\le100) N(100), the number of test locations. Then N N N ranklists follow, each starts with a line containing a positive integer K ( ≤ 300 ) K (\le300) K(300), the number of testees, and then K K K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N N N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

思路

这是一道比较简单的排序题,需要注意的就是相同分数,要按照编号排序;最后一个测试点数据量比较大,还要注意算法的效率问题,主要在排序耗时,我是直接采用STL sort()函数,内部用分治和快排实现,是非常高效的排序算法。

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;

struct testee{
    string id;
    int score;
    int location;
    int localRank;
};

bool cmp(testee a, testee b){
    return a.score != b.score ? a.score > b.score:a.id < b.id;
}

int main(){
    int n, k;
    vector<testee> testees;
    scanf("%d", &n);
    for(int i=1; i<=n; i++){
        scanf("%d", &k);
        vector<testee> tmp(k);
        for(int j=0; j<k; j++){
            cin>>tmp[j].id>>tmp[j].score;
            tmp[j].location = i;
        }
        sort(tmp.begin(), tmp.end(), cmp);
        int t = 1;
        for(int j=0; j<k-1; j++){
            tmp[j].localRank = t;
            testees.push_back(tmp[j]);
            if(tmp[j].score > tmp[j+1].score)
                t = j + 2;
        }
        tmp[k-1].localRank = t;
        testees.push_back(tmp[k-1]);
    }
    sort(testees.begin(), testees.end(), cmp);
    int t = 1, co = testees.size();
    printf("%d\n", co);
    for(int j=0; j<co-1; j++){
        cout<<testees[j].id<<" "<<t<<" "<<testees[j].location<<" "<<testees[j].localRank<<endl;
        if(testees[j].score > testees[j+1].score)
            t = j + 2;
    }
    cout<<testees[co-1].id<<" "<<t<<" "<<testees[co-1].location<<" "<<testees[co-1].localRank<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值