PAT甲级【2019年9月考题】——A1162 MergingLinkedLists【25】

7-2 Merging Linked Lists (25 分)

Given two singly linked lists L 1 =a 1 →a 2 →...→a n−1 →a n  L1=a1→a2→...→an−1→an and L 2 =b 1 →b 2 →...→b m−1 →b m  L2=b1→b2→...→bm−1→bm . If n≥2m n≥2m , you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a 1 →a 2 →b m →a 3 →a 4 →b m−1 ... a1→a2→bm→a3→a4→bm−1... For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.

Input Specification

Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L 1  L1 and L 2  L2 , plus a positive N(≤10 5 ) N(≤105) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is a positive integer no more than 10 5  105 , and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.

Output Specification

For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input

00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

Sample Output

01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

 

【声明】

  由于此题还未上PAT官网题库,故没有测试集,仅仅是通过了样例,若发现错误,感谢留言指正。

Solution:

  很简单,就是先把节点数据存储下来,然后分别获取出两条链表的节点,然后进行按要求拼接。

#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;
struct Node
{
	int addr, val, next;
}nodes[100010];
int main()
{
	int head, head1, head2, n;
	cin >> head1 >> head2 >> n;
	vector<Node>v1, v2, res;//存储列表值
	for (int i = 0; i < n; ++i)
	{
		int a, b, c;
		cin >> a >> b >> c;
		nodes[a] = { a,b,c };
	}
	for (int p = head1; p != -1; p = nodes[p].next)
		v1.push_back(nodes[p]);
	for (int p = head2; p != -1; p = nodes[p].next)
		v2.push_back(nodes[p]);
	if (v1.size() > v2.size())
		head = head1;
	else
	{
		v2 = v1;//v2是短边
		head = head2;
	}
	int k = 0;
	while (head != -1)
	{
		res.push_back(nodes[head]);
		++k;
		if (k % 2 == 0 && !v2.empty())//两个中间插一个
		{
			res.push_back(v2.back());
			v2.pop_back();
		}
		head = nodes[head].next;
	}
	for (int i = 0; i < res.size() - 1; ++i)
		printf("%05d %d %05d\n", res[i].addr, res[i].val, res[i+1].addr);
	printf("%05d %d %d\n", res.back().addr, res.back().val, -1);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值