PTA Merging Linked Lists

题目

Given two singly linked lists L 1 ​ = a 1 ​ → a 2 ​ → ⋯ → a n − 1 ​ → a n L_1​=a_1​→a_2​→⋯→a_{n−1}​→a_n L1=a1a2an1an​ and L 2 ​ = b 1 ​ → b 2 ​ → ⋯ → b m − 1 ​ → b m L_2​=b_1​→b_2​→⋯→b_{m−1}​→b_m L2=b1b2bm1bm​. If n≥2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a 1 ​ → a 2 ​ → b m ​ → a 3 ​ → a 4 ​ → b m − 1 ​ ⋯ a_1​→a_2​→b_m​→a_3​→a_4​→b_m−1​⋯ a1a2bma3a4bm1. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.

大意

给定两条链表以及他们的首地址,保证长链表的长度比短链表的两倍和还要长,将短链表逐个按照每两个元素插入长链表中,最终输出整个链表。

输入

Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L 1 ​ L_1​ L1 and L 2 L_2 L2​, plus a positive N (≤ 1 0 5 10^5 105) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is a positive integer no more than 1 0 5 10^5 105, and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.

输出

For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

输入样例

00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

输出样例

01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

题目分析

首先架构一个结构体数组,包含该结构的地址,数据,下一个地址。采用数组的形式,数组下标与该结构地址相同,随后按照地址寻找各数据点下标,由下标寻觅下一个结点。在输出时注意将上下结点的地址进行修改。

代码

#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;

struct Node{
	int former,data,next;
};
vector<Node> list1,list2;

int main(){
	int head1,head2,n;
	cin >> head1>>head2>>n;
	struct Node a[100005];
	int mark;
	for(int i = 0;i<n;++i){
		cin >> mark;
		a[mark].former=mark;//利用下标与代表地址
		cin>>a[mark].data>>a[mark].next;
	}
	int t = head1;//寻找链表
	while(t!=-1){
		list1.push_back(a[t]);
		t = a[t].next;
	}
	t = head2;
	while(t!=-1){
		list2.push_back(a[t]);
		t = a[t].next;
	}
	if(list1.size()<list2.size()) swap(list1,list2);//确保链表1是长链表,便于输出
	t = list2.size();
	printf("%05d %d ",list1[0].former,list1[0].data);
	for(int i = 1;i<list1.size();++i){
		printf("%05d\n%05d %d ",list1[i].former,list1[i].former,list1[i].data);
		if(i%2==1&&t!=0){//隔2插入
			printf("%05d\n%05d %d ",list2[t-1].former,list2[t-1].former,list2[t-1].data);
			--t;
		}
	}
	printf("-1\n");
	return 0;
}

运行结果

在这里插入图片描述

  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

registor11

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值