「1161」Merging Linked Lists

Given two singly linked lists  ​ and  ​. If  , you are supposed to reverse and merge the shorter one into the longer one to obtain a list like  ​⋯. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.

Input Specification:

Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L1​ and L2​, plus a positive  which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is a positive integer no more than  , and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.

Output Specification:

For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

Sample Output:

01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

Ω

链表水题放松。给出两个链表,长度分别为 ,需要你将短链表反向隔2插入到长链表中。

首先读入所有节点,用map建立地址到节点值以及下一个节点地址的映射。然后通过头节点遍历链表,将每个节点的地址及值存储到vector<pair<int,int>>中。最后每输出两个长链表节点,就反向输出一个短链表节点。短链表输完后需要把长链表剩余节点一次性输出。


🐎

#include <iostream>
#include <vector>
#include <map>

using namespace std;

inline void output(pair<int, int> &p)
{
    static bool flag = false;
    if (flag) printf(" %05d\n", p.first);
    printf("%05d %d", p.first, p.second);
    flag = true;
}

int main()
{
    int sa, sb, n, a, v, nxt, j;
    cin >> sa >> sb >> n;
    map<int, pair<int, int>> node;
    for (int i = 0; i < n; ++i)
    {
        cin >> a >> v >> nxt;
        node[a] = make_pair(v, nxt);
    }
    vector<pair<int, int>> l1, l2;
    while (sa != -1)
        l1.emplace_back(sa, node[sa].first), sa = node[sa].second;
    while (sb != -1)
        l2.emplace_back(sb, node[sb].first), sb = node[sb].second;
    if (l1.size() < l2.size()) swap(l1, l2);
    for (j = 0; j < 2 * l2.size(); j += 2)
        output(l1[j]), output(l1[j + 1]), output(l2[l2.size() - j / 2 - 1]);
    for (; j < l1.size(); ++j) output(l1[j]);
    printf(" -1");
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值