PAT甲级——A1010 Radix

题目

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

Solution:

题意:
根据给出的数,求出另一个数的满足要求的进制

题解:
这题不难,主要是要考虑数据溢出的问题(巨恶心,搞了我半天)
记得要使用二分法去寻找匹配的进制(这个一超时就能想起)

Code


#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
using namespace std;
string n, m;
int t, k;
//根据进制计算十进制数值
long long calValue(string x, long long r)
{
	if (r == 10)return atoi(x.c_str());
	long long sum = 0, k = 1;
	for (int i = x.length()-1;i>=0;--i)
	{
		sum += k * (isalpha(x[i]) ? (x[i] - 'a' + 10) : (x[i] - '0'));
		k *= r;
	}
	return sum;
}

long long calRadix(string x)
{
	//首先计算x中的最大数值
	int maxV = 0;
	for (auto a : x)
		maxV = max(maxV, isalpha(a) ? (a - 'a' + 10) : (a - '0'));
	long long nV = calValue(n, k);//计算n的十进制数
	long long L = maxV + 1, R = nV > 36 ? nV : 36, mid;//一定得使用二分法
	while (L <= R)
	{
		mid = L + (R - L) / 2;
		long long mV = calValue(x, mid);
		if (nV == mV)
			return mid;
		if (mV > nV || mV<0)//mV<0表示溢出,进制太大了
			R = mid - 1;
		else
			L = mid + 1;
	}
	return -1;
}
int main()
{
	cin >> n >> m >> t >> k;
	if (t == 2)
		swap(n, m);//记住n为已知的进制数
	long long res = calRadix(m);
	if(res>-1)
		cout << res << endl;
	else
		printf("Impossible");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值