HDU - 4027 Can you answer these queries?(线段树 区间改变 变成平方根)

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 23472    Accepted Submission(s): 5585


 

Problem Description

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

 

 

Input

The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

 

 

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

 

 

Sample Input

 

10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8

 

 

Sample Output

 

Case #1: 19 7 6

 

 

Source

The 36th ACM/ICPC Asia Regional Shanghai Site —— Online Contest

 

 

Recommend

lcy

 

 

线段树板子题,一个优化就是变成一以后就不在开根了;

听说照着板子敲一下就行了,然后写的时候犯蠢,主函数里有个地方m写成了n,和我的小伙伴一起找bug,

都以为是更新函数有问题,硬生生改了一个多小时,最后和找到bug的小伙伴成功笑疯,默默的觉得对不起小伙伴;

然后就开起了花式超时之路,最后让同学帮我改好了,他用改了的代码ac,而我一样的代码各种花式错误,怀疑人生qwq,

最后让小姐姐帮忙交了,才发现g++可以ac,而c++不行,(大雾),知道真相的我哇的一声哭出来;

不服气,问了大佬,结果大佬说,因为我交的姿势不优雅??(黑人问号脸);

这个看脸的世界,呜呜呜

 

对了,一个坑点就是,输入的x,y,并不一定是x<y;这里要判断一下

 

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
#include <map>
#include <string>
#include <queue>
#include <stack>
#include <set>
#include <list>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;

char w[10];

ll read() {//输入输出挂,一定要记得改返回值类型,呜呜呜
    ll ans = 0;
    char ch;
    do {
        ch = getchar();
    } while(ch < '0' || ch > '9');
    do {
        ans = ans * 10 + ch - '0';
        ch = getchar();
    } while(ch >= '0' && ch <= '9');
    return ans;
}

void write(ll x) {
    if(x == 0) {
        putchar('0');
    } else {
        int cnt = 0;
        while(x != 0) {
            w[cnt] = x % 10 + '0';
            ++cnt;
            x /= 10;
        }
        do {
            --cnt;
            putchar(w[cnt]);
        } while(cnt > 0);
    }
}

ll n,m;
const int maxn = 1e5+5;
ll tree[maxn<<2];

void build(ll l,ll r,ll rt){//建树
    if(l==r){
        tree[rt]=read();
        return;
    }

    ll mid = (l+r)>>1;
    build(l,mid,rt<<1);
    build(mid+1,r,rt<<1|1);
    tree[rt] = tree[rt<<1] + tree[rt<<1|1];
}

ll query(ll L,ll R,ll l,ll r,ll rt){//查询
    if(L <= l && r <= R) return tree[rt];
    ll mid = (l+r)>>1;
    ll ans = 0;
    if(L <= mid) ans+=query(L,R,l,mid,rt<<1);
    if(mid < R)  ans+=query(L,R,mid+1,r,rt<<1|1);
    return ans;
}

void  solve(ll L,ll R,ll l,ll r,ll rt){//更新
    if(L>r || R<l) return;
    if(l>=L && r<=R && tree[rt] == r-l+1) return;//优化,值为一的平方根一直为1
    if(l == r){
        tree[rt] = (ll)sqrt(tree[rt]);
        return;
    }
    ll mid = (l+r)>>1;
    if(L<=mid) solve(L,R,l,mid,rt<<1);
    if(mid<R) solve(L,R,mid+1,r,rt<<1|1);
    tree[rt] = tree[rt<<1] + tree[rt<<1|1];
}

int main()
{
    int k = 1;
    while(~scanf("%lld",&n)){
            printf("Case #%d:\n",k++);
    build(1,n,1);
    m=read();
    while(m--){//这里写成了n,这种小细节问题,还不容易找出来,知道真相的我真想敲死自己
        int a,b,c;
        a=read();b=read();c=read();
        if(a){
            write(query(min(b,c),max(c,b),1,n,1));//注意输出挂的输出类型!!
            putchar('\n');
        }
        else solve(min(b,c),max(c,b),1,n,1);//输出的b,c没有规定大小
    }
    putchar('\n');
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值