POJ - 2236 Wireless Network 【并查集】

Description:

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS 

题意&分析: 

n台损坏的电脑,去修复,已经修复的距离小于d的电脑可以联系,问两台电脑是否可以直接或间接联系。

每修复一台电脑就维护一遍并查集。

AC代码

#include <iostream>
#include <cstdlib>
#include <cstring>
using namespace std;
struct loc {
    int x,y;
}locc[1005];
int f[1005],n,d;
bool book[1005];
void init()
{
    for(int i=1;i<=n;i++)
        f[i]=i;
}
int getf(int v)
{
    if(f[v] == v)
        return v;
    f[v]=getf(f[v]);
    return f[v];
}
void Merge(int t1,int t2)
{
    int f1,f2;
    f1 = getf(t1);
    f2 = getf(t2);
    if(f1 != f2)
        f[f2] = f1;
    return;
}
void Judge(int j,int t1)
{
        if(j != t1 && book[j])
            if((locc[t1].x-locc[j].x)*(locc[t1].x-locc[j].x)+(locc[t1].y-locc[j].y)*(locc[t1].y-locc[j].y) <= d*d)
                Merge(j,t1);
}
int main()
{
    cin >> n >> d;
    init();
    for(int i=1;i<=n;i++)
        cin >> locc[i].x >> locc[i].y;

    memset(book,false,sizeof book);
    char ch;
    int t1,t2;
    while( cin >> ch) {
        if(ch == 'S') {
            cin >> t1 >> t2;
            if(book[t1] == true && book[t2] == true && getf(t1)==getf(t2))
                cout << "SUCCESS\n";
            else
                cout << "FAIL\n";
        }
        else {
            cin >> t1;
            book[t1]=true;
            for(int j=1;j<=n;j++)
                Judge(j,t1);
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值