题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016
Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
分析:
这个题要在求排列的时候就判断是否为素数,发现已经有相邻两数和不是素数的情况就不再继续求这个排列(剪枝),要是先求出一个完整的排列再判断会超时。
AC代码
#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
int a[21];
bool book[21];
int N;
bool IsPrime(int n)
{
for(int i=2;i<=sqrt(n);i++)
if(n%i == 0)
return false;
return true;
}
void dfs(int step) // 确定第step+1个数
{
if(step == N) {
if( IsPrime(a[step]+a[1])) {
for(int i=1;i<=N;i++) {
cout << a[i];
if(i != N)
cout << " ";
}
cout << endl;
}
return;
}
for(int i=2;i<=N;i++) {
if( !book[i] && IsPrime(a[step]+i)) {
a[step+1] = i;
book[i] = true;
dfs(step+1);
book[i] = false;
}
}
}
int main()
{
int Case=1;
while(cin >> N) {
memset(book,false,sizeof book);
a[1] = 1;
book[1] = true;
cout << "Case " << Case++ << ":" << endl;
dfs(1);
cout << endl;
}
}