HDU - 1016 Prime Ring Problem 【 dfs (全排列)+ 剪枝】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016

Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

Input

n (0 < n < 20). 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

分析:

这个题要在求排列的时候就判断是否为素数,发现已经有相邻两数和不是素数的情况就不再继续求这个排列(剪枝),要是先求出一个完整的排列再判断会超时。

AC代码

#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
int a[21];
bool book[21];
int N;
bool IsPrime(int n)
{
    for(int i=2;i<=sqrt(n);i++)
        if(n%i == 0)
            return false;
    return true;
}
void dfs(int step)  // 确定第step+1个数
{
    if(step == N) {
        if( IsPrime(a[step]+a[1])) {
            for(int i=1;i<=N;i++) {
                cout << a[i];
                if(i != N)
                    cout << " ";
            }
            cout << endl;
        }
        return;
    }
    for(int i=2;i<=N;i++) {
        if( !book[i] && IsPrime(a[step]+i)) {
            a[step+1] = i;
            book[i] = true;
            dfs(step+1);
            book[i] = false;
        }
    }
}
int main()
{
    int Case=1;
    while(cin >> N) {
        memset(book,false,sizeof book);
        a[1] = 1;
        book[1] = true;
        cout << "Case " << Case++ << ":" << endl;
        dfs(1);
        cout << endl;
    }

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值