1154 Vertex Coloring (25 分)
A proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.
Now you are supposed to tell if a given coloring is a proper k-coloring.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.
Output Specification:
For each coloring, print in a line k-coloring
if it is a proper k
-coloring for some positive k
, or No
if not.
Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9
Sample Output:
4-coloring
No
6-coloring
No
【分析】图论 + k-coloring
总结:
图论里有个著名的四色猜想,题目的来源大概是这个。这题目有点简单了。。
不能直接用n * n 矩阵存储,会超出内存。
#include <iostream>
#include <cstdio>
#include <stdlib.h>
#include <string.h>
#include <vector>
#include <set>
using namespace std;
const int maxn = 1e4 + 5;
int n, m, k;
vector<int> edge[maxn];
int color[maxn];
void solve() {
int flag = 1;
set<int> s;
for (int i = 0; i < n; i++) {
for (int j = 0; j < edge[i].size(); j++) {
if (color[i] == color[edge[i][j]]) {
flag = 0;
break;
}
}
}
if (!flag) printf("No");
else {
for (int i = 0; i < n; i++) s.insert(color[i]);
printf("%d-coloring", s.size());
}
}
int main() {
cin >> n >> m;
for (int i = 0; i < m; i++) {
int u, v;
cin >> u >> v;
edge[u].push_back(v);
edge[v].push_back(u);
}
cin >> k;
for (int i = 0; i < k; i++) {
for (int i = 0; i < n; i++) scanf("%d", &color[i]);
solve();
if (i != k - 1) printf("\n");
}
return 0;
}