CSU暑期集训day03_Queries about less or equal elements

题目:

You are given two arrays of integers a and b. For each element of the second array bj you should find the number of elements in array athat are less than or equal to the value bj.

Input

The first line contains two integers n, m (1 ≤ n, m ≤ 2·105) — the sizes of arrays a and b.

The second line contains n integers — the elements of array a ( - 109 ≤ ai ≤ 109).

The third line contains m integers — the elements of array b ( - 109 ≤ bj ≤ 109).

Output

Print m integers, separated by spaces: the j-th of which is equal to the number of such elements in array a that are less than or equal to the value bj.

Sample Input

5 4
1 3 5 7 9
6 4 2 8
5 5
1 2 1 2 5
3 1 4 1 5

Sample Output

3 2 1 4
4 2 4 2 5

题目大意:

    给出两组数字,要求找出第一个数组中小于等于第二个数组中的每个数字的个数。

解题思路:

    对第一个数组排序,依次在其中二分查找每个第二个数组中的数字。

代码:

#include <iostream>
#include <cstdio> 
#include <algorithm>

using namespace std;

int main(){
    int n,m;
    while(cin>>n>>m){
        int nrr[200002]={1000000002};        
        for(int i=0;i<n;i++){
            scanf("%d",&nrr[i]);
        }
        sort(nrr,nrr+n);
        for(int i=0;i<m;i++){
            int mrr;
            scanf("%d",&mrr);      
            int left=0;
            int right=n;
            int mid;
            while(right>left){
                mid=(left+right)/2;
                if(nrr[mid]<mrr+1)left=mid+1;
                else right=mid;
            }
            printf("%d ",left);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值