PTA Advanced 1161 Merging Linked Lists C++

目录

题目

Input Specification:

Output Specification:

Sample Input:

Sample Output:

思路

代码


题目

Given two singly linked lists L1​=a1​→a2​→⋯→an−1​→an​ and L2​=b1​→b2​→⋯→bm−1​→bm​. If n≥2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a1​→a2​→bm​→a3​→a4​→bm−1​⋯. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.

Input Specification:

Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L1​ and L2​, plus a positive N (≤105) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is a positive integer no more than 105, and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.

Output Specification:

For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

Sample Output:

01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

思路

能想到翻转链表头插法即可

然后我是用map去存储结点的,链表指针就相当于map的key,链表结点信息是map的value,我构造了一个Node结构体

代码

#include <iostream>
#include <map>

using namespace std;

struct Node{
	int data,next;
};

map<int,Node> nodes;

int main(int argc, char** argv) {
	int link1,link2,n;
	cin>>link1>>link2>>n;
	
	// 将结点以map的形式存入,key是结点地址,value是结点值以及next的地址
	for(int i=0;i<n;i++){
		int address,data,next;
		cin>>address>>data>>next;
		
		Node node;
		node.data=data;
		node.next=next;
		nodes[address]=node;
	} 
	
	// 统计两个link的长度,将link1始终设置成短的那一个
	int p1=link1,p2=link2;
	while(nodes[p1].next!=-1&&nodes[p2].next!=-1){
		p1=nodes[p1].next;
		p2=nodes[p2].next;
	} 
	if(nodes[p2].next==-1){// link2更短时 
		int temp=link1;
		link1=link2;
		link2=temp; 
	} 
	
	// 对link1采用头插法翻转
	p1=link1;
	p2=nodes[link1].next;
	while(p2!=-1){
		nodes[p1].next=nodes[p2].next;
		nodes[p2].next=link1;
		link1=p2;
		
		p2=nodes[p1].next;// 指针后移 
	}
	
	// 开始link1和link2的插入
	p1=link1;
	p2=link2;
	int flag=0;
	while(p1!=-1){
		// 需要插入时 
		if(flag==1){
			link1=nodes[p1].next;
			nodes[p1].next=nodes[p2].next;
			nodes[p2].next=p1;
			p2=p1; 
			p1=link1;
		}
		p2=nodes[p2].next;
		flag=(flag+1)%2; 
	} 
	
	// 输出link2
	p2=link2;
	while(p2!=-1){
		printf("%05d %d ",p2,nodes[p2].data);
		p2=nodes[p2].next;
		if(p2==-1) cout<<-1<<endl;
		else printf("%05d\n",p2);
	} 
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值