Bone Collector(动态规划-dp-01背包裸题)

Bone Collector(动态规划-dp-01背包裸题)

source:hduoj 2602
Time limit:2000 ms
Memory limit:32768 kB
OS:Windows

描述

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

在这里插入图片描述

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

题意

你有一个背包,背包有一个最大容量。
你面前有一堆骨头,每个骨头有一定的价值也有一定的体积。
问你如何挑选骨头能使你拿的价值最大化。

01背包模板题不解释。不懂去翻背包九讲。

代码

#include <bits/stdc++.h>
#define maxn 1005
#define inf 0x3f3f3f3f
#define ll long long
#define _for(i, a) for(ll i = 0; i < (a); i++)
#define _rep(i, a, b) for(ll i = (a); i <= (b); i++)
using namespace std;
ll v[maxn], w[maxn];
ll dp[maxn];
ll n, V;
int main() {
	ll T;
	cin >> T;
	_for(Case, T) {
		cin >> n >> V;
		_for(i, n) cin >> v[i];
		_for(i, n) cin >> w[i];
		memset(dp, 0, sizeof(dp));
		_for(i, n) {
			for (ll j = V; j >= w[i]; j--) {
				dp[j] = max(dp[j], dp[j - w[i]] + v[i]);
			}
		}
		cout << dp[V] << "\n";
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值