Cutting Sticks(动态规划-区间dp)

Cutting Sticks(动态规划-区间dp)

judge:scuoj 1702
Time limit:3000 ms
OS:Linux

Description

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time.
It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.

Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

Input

The input will consist of several input cases. The first line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000 l < 1000 l<1000. The next line will contain the number n ( n < 50 ) n ( n < 50) n(n<50) of cuts to be made.
The next line consists of n positive numbers c i ( 0 < c i < l ) c_i ( 0 < c_i < l) ci(0<ci<l) representing the places where the cuts have to be done, given in strictly increasing order.

An input case with l = 0 l = 0 l=0 will represent the end of the input.

Output

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.

Sample Input
100
3
25 50 75
10
4
4 5 7 8
0
Sample Output
The minimum cutting is 200.
The minimum cutting is 22.
题意

给你一根木头,长度为l,切割厂切木头的费用是按木头的长度算的,加入要切一根长度为100的木头那么费用就是100.而要把长度一定的木头切割成长度不一的小段,那么可以发现切割顺序不同其最终需要的费用是不同的。

此时给你一些切割点,问你通过最优的切割顺序,其最低的切割费用是多少。

先转换条件,把题中给的切割点转换成切割完毕后的短木头的长度。然后3层循环区间dp找出最优解。

代码
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#define _for(i, a) for(int i = 0; i < (a); i++)
#define _rep(i, a, b) for(int i = (a); i<= (b); i++)
typedef long long ll;
const int maxn = 1005;
const int inf = 0x3f3f3f3f;
using namespace std;
int dp[maxn][maxn];
int a[maxn];
int f[maxn][maxn];
int main() {
	//freopen("in.txt", "r", stdin);
	int l, n;
	while (cin >> l, l) {
		cin >> n;
		memset(f, 0, sizeof(f));
		memset(dp, 0, sizeof(dp));
		_for(i, n) {
			scanf("%d", a + i);
		}
		a[n] = l - a[n - 1];
		for (int i = n - 1; i >= 0; i--) a[i] -= a[i - 1];
		n++;
		_for(i, n) f[i][i] = a[i];
		_rep(d, 0, n) {
			for (int i = 0, j = i + d - 1; j < n; i++, j++) {
				for (int k = i; k < j; k++) {
					f[i][j] = f[i][k] + f[k + 1][j];
					if (dp[i][j] == 0) {
						dp[i][j] = dp[i][k] + dp[k + 1][j] + f[i][j];
					}
					else {
						dp[i][j] = min(dp[i][j], dp[i][k] + dp[k + 1][j] + f[i][j]);
					}
				}
			}
		}
		printf("The minimum cutting is %d.\n", dp[0][n - 1]);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值